HDP on Windows – Installation Forum

HDP Installation Unsuccessful

  • #40833


    I am trying to install hdp on windows server 2008 R2 64 bit,and at the first time it showed a message that installation completed successfully.But when i started the services some services failed so i ran the smoke test and all the components status is failed except for 2 .then i am trying to re-install it but it is not allowing me to re-install.it is showing an error “Installation failed”see the log D:\HadoopInstallFiles\HadoopSetupTools\winpkg.log but these folder is not even created to see the error.

to create new topics or reply. | New User Registration

  • Author
  • #40875
    Seth Lyubich

    Hi Bharath,

    Please check forum link below is helpful:


    If you need to reinstall, please try to uninstall HDP first and set DESTROY_DATA=YES.

    Hope this helps.



    Hi Seth
    I have uninstalled the hadoop using the cmd line “msiexec /x “hdp-” /lv “hdp.log” DESTROY_DATA=”yes” “and even tried with “msiexec /i “hdp-” /lv “hdp.log” HDP_LAYOUT=”d:\HDP\clusterproperties.txt” HDP_DIR=”d:\hadoop” DESTROY_DATA=”yes” ” and tried installing it again and it showed the same error.

    here is the “hdp.log” for the error
    MSI (s) (F4:08) [14:27:00:763]: Running as a service.
    CAQuietExec: Error 0x80070001: Command line returned an error.
    CAQuietExec: Error 0x80070001: CAQuietExec Failed
    CustomAction UninstallDeferred returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 14:27:00: InstallFinalize. Return value 3.
    User policy value ‘DisableRollback’ is 0
    User policy value ‘DisableRollback’ is 0
    Machine policy value ‘DisableRollback’ is 0
    Executing op: Header(Signature=1397708873,Version=500,Timestamp=1129476961,LangId=1033,Platform=0,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
    Executing op: DialogInfo(Type=0,Argument=1033)
    Executing op: DialogInfo(Type=1,Argument=Hortonworks Data Platform for Windows)
    Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])
    Executing op: ActionStart(Name=UninstallDeferred,,)
    Executing op: ProductInfo(ProductKey={5F733BFC-CACA-411F-A6DC-5AA3ED611F1C},ProductName=Hortonworks Data Platform for Windows,PackageName=hdp-,Language=1033,Version=16973824,Assignment=1,ObsoleteArg=0,,,PackageCode={615E9813-C138-4A72-8400-7FEDB5D19DDF},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=3)
    Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=0)
    Error in rollback skipped. Return: 5
    Action ended 14:27:00: ExecuteAction. Return value 3.
    Doing action: INSTFAILED
    Note: 1: 2205 2: 3: ActionText
    Action start 14:27:00: INSTFAILED.
    Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

    Note: 1: 2262 2: Error 3: -2147287038
    Product: Hortonworks Data Platform for Windows — Installation failed. Please see installation log for details: D:\HadoopInstallFiles\HadoopSetupTools\hdp-
    INSTFAILED. Return value 3.
    INSTALL. Return value 3.
    === Logging stopped: 10/18/2013 14:27:02 ===
    Note: 1: 1729
    Note: 1: 2262 2: Error 3: -2147287038
    Note: 1: 2262 2: Error 3: -2147287038
    Product: Hortonworks Data Platform for Windows — Configuration failed.
    Windows Installer reconfigured the product. Product Name: Hortonworks Data Platform for Windows. Product Version: Product Language: 1033. Manufacturer: Hortonworks. Reconfiguration success or error status: 1603.
    Grabbed execution mutex.
    Cleaning up uninstalled install packages, if any exist
    MainEngineThread is returning 1603
    === Verbose loggi

    Seth Lyubich

    Hi Bharath,

    Can you please make sure that name resolution is configured correctly and that Java and Python home is specified correctly in the environmental variables? Also, can you please share D:\HadoopInstallFiles\HadoopSetupTools\hdp- as it might have more information on the issue.


    Vimal Raj

    Trying to install hdp 1.3.0 in 32bit windows. And while installing its asking for visual c++ 64 bit. But my windows is 32 bit. Any source to download 32 bit hdp 1.3.0?
    Please share if any source available or any other alternate method to install 64 bit hdp into 32 bit system.?

    Seth Lyubich

    Hi Vimal,

    This seems to be a different issue. Please see OS requirements below. Currently HDP support only 64 bit systems.


    Hope this helps,


You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.