Home Forums HDP on Linux – Installation HDP Installation

This topic contains 1 reply, has 2 voices, and was last updated by  Dave 1 year, 1 month ago.

  • Creator
    Topic
  • #34232

    Manickam P
    Member

    I tried to install HDP in my server. I got the below error. Please help.

    Error: Package: postgresql-server-8.1.23-6.el5_8.x86_64 (el5_latest)
    Requires: postgresql = 8.1.23-6.el5_8
    Installed: postgresql-8.4.11-1.el6_2.x86_64 (@anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3)
    postgresql = 8.4.11-1.el6_2
    Available: postgresql-8.1.22-1.el5_5.1.x86_64 (el5_latest)
    postgresql = 8.1.22-1.el5_5.1
    Available: postgresql-8.1.23-1.el5_6.1.x86_64 (el5_latest)
    postgresql = 8.1.23-1.el5_6.1
    Available: postgresql-8.1.23-1.el5_7.2.x86_64 (el5_latest)
    postgresql = 8.1.23-1.el5_7.2
    Available: postgresql-8.1.23-1.el5_7.3.x86_64 (el5_latest)
    postgresql = 8.1.23-1.el5_7.3
    Available: postgresql-8.1.23-4.el5_8.x86_64 (el5_latest)
    postgresql = 8.1.23-4.el5_8
    Available: postgresql-8.1.23-5.el5_8.x86_64 (el5_latest)
    postgresql = 8.1.23-5.el5_8
    Available: postgresql-8.1.23-6.el5_8.x86_64 (el5_latest)
    postgresql = 8.1.23-6.el5_8
    Available: postgresql84-8.4.5-1.el5_5.1.x86_64 (el5_latest)
    postgresql = 8.4.5-1.el5_5.1
    Available: postgresql84-8.4.7-1.el5_6.1.x86_64 (el5_latest)
    postgresql = 8.4.7-1.el5_6.1
    Available: postgresql84-8.4.9-1.el5_7.1.x86_64 (el5_latest)
    postgresql = 8.4.9-1.el5_7.1
    Available: postgresql84-8.4.11-1.el5_8.x86_64 (el5_latest)
    postgresql = 8.4.11-1.el5_8
    Available: postgresql84-8.4.12-1.el5_8.x86_64 (el5_latest)
    postgresql = 8.4.12-1.el5_8
    Available: postgresql84-8.4.13-1.el5_8.x86_64 (el5_latest)
    postgresql = 8.4.13-1.el5_8
    Error: Package: postgresql-server-8.1.23-6.el5_8.x86_64 (el5_latest)
    Requires: libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.22-1.el5_5.1.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-1.el5_6.1.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-1.el5_7.2.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-1.el5_7.3.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-4.el5_8.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-5.el5_8.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Available: postgresql-libs-8.1.23-6.el5_8.x86_64 (el5_latest)
    libpq.so.4()(64bit)
    Installed: postgresql-libs-8.4.11-1.el6_2.x86_64 (@anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3)
    Not found
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #34257

    Dave
    Moderator

    Hi Manickam,

    What OS is this installed on? It looks like it’s looking for el5 installation of PSQL when it has installed el6.
    So you either have installed the incorrect version of PSQL for your OS, or you are using the incorrect repository.

    Thanks

    Dave

    Collapse
Viewing 1 replies (of 1 total)