Home Forums Oozie Hive query using Oozie is not successful

This topic contains 2 replies, has 1 voice, and was last updated by  Karthick S 1 year, 1 month ago.

  • Creator
    Topic
  • #33357

    Karthick S
    Member

    Hi,
    I have created a table new(id int). Now I am trying to update the table using hive via oozie. It does not throw any error but Hive actions keeps on going. Here are the related files
    WORKFLOW.XML:

    ${jobTracker}
    ${nameNode}

    <!–
    –>

    hive-site.xml

    mapred.job.queue.name
    ${queueName}

    oozie.log.hive.level
    DEBUG

    oozie.hive.defaults
    hive-site.xml

    script.q

    Hive failed, error message[${wf:errorMessage(wf:lastErrorNode())}]

    Configuration:
    jobTracker sandbox:50300
    nameNode hdfs://sandbox:8020
    oozie.libpath /user/oozie/share/lib/hive
    oozie.use.system.libpath true
    oozie.wf.application.path hdfs://sandbox:8020/user/hue/demo2
    queueName default
    user.name hue

    SCRIPT.Q
    load data inpath ‘demo1/data.txt’ into new;

    Log from the job:
    2013-08-27 03:07:12,903 DEBUG DefinitionXCommand:545 – USER[hue] GROUP[-] TOKEN[] APP[hive-add-wf] JOB[0000002-130826232141308-oozie-oozi-W] ACTION[-] Execute command [definition] key [0000002-130826232141308-oozie-oozi-W]
    2013-08-27 03:07:14,717 DEBUG DefinitionXCommand:545 – USER[hue] GROUP[-] TOKEN[] APP[hive-add-wf] JOB[0000002-130826232141308-oozie-oozi-W] ACTION[-] Execute command [definition] key [0000002-130826232141308-oozie-oozi-W]
    2013-08-27 03:07:16,679 DEBUG DefinitionXCommand:545 – USER[hue] GROUP[-] TOKEN[] APP[hive-add-wf] JOB[0000002-130826232141308-oozie-oozi-W] ACTION[-] Execute command [definition] key [0000002-130826232141308-oozie-oozi-W]
    2013-08-27 03:07:32,234 DEBUG DefinitionXCommand:545 – USER[hue] GROUP[-] TOKEN[] APP[hive-add-wf] JOB[0000002-130826232141308-oozie-oozi-W] ACTION[-] Execute command [definition] key [0000002-130826232141308-oozie-oozi-W]
    2013-08-27 03:07:45,982 DEBUG DefinitionXCommand:545 – USER[hue] GROUP[-] TOKEN[] APP[hive-add-wf] JOB[0000002-130826232141308-oozie-oozi-W] ACTION[-] Execute command [definition] key [0000002-130826232141308-oozie-oozi-W]

    Thanks in advance.
    Karthick

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #33513

    Karthick S
    Member

    The same setup above worked successfully with the query:
    insert overwrite table new_col select col1 from cor;

    Probably the issue is with the way query is framed. Will update the exact issue once i get more clarity

    Collapse
    #33358

    Karthick S
    Member

    For some reason the workflow.xml did not get pasted right: So once again pasting it here,

    ${jobTracker}
    ${nameNode}

    <!–
    –>

    hive-site.xml

    mapred.job.queue.name
    ${queueName}

    oozie.log.hive.level
    DEBUG

    oozie.hive.defaults
    hive-site.xml

    script.q

    Hive failed, error message[${wf:errorMessage(wf:lastErrorNode())}]

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)