Home Forums Hortonworks Sandbox How to configure a Host-only network adapter with DHCP enabled on Windows 7

This topic contains 3 replies, has 2 voices, and was last updated by  Robert 1 year, 4 months ago.

  • Creator
    Topic
  • #21244

    I am following http://goo.gl/HOyO4 to get the sandbox up and running on a Windows 7 64-bit Operating System with 4GB RAM which runs VMware Player version 5.0.0 build-812388.

    The above mentioned instruction manual (in page-2 paragraph-2) highlights that “To use the Sandbox, you should have a Host-only network adapter with DHCP enabled”. However it covers only the first part of this statement which is “to setup a Host-only network adapter” but does not cover “how to have DHCP enabled for that Host-only network adapter”

    When I power-on the sandbox with the default setup which is one NAT (eth0) and one Host-only (eth1), the sandbox Linux boot up failed to bring up the interface for eth1 (which is Host-only). The exact error is “Determining IP information for eth1… failed; no link present. Check cable? [FAILED]“.

    And when the sandbox is up, it highlights “Connectivity issue detected! Check connection of Host-only interface and check DHCP is enabled for it” and no IP address (URL) is displayed!

    On my host Windows 7, I ensured that VMware DHCP Service is running [control panel > administrative tools > services > VMware DHCP Service]

    How could I setup a Host-only network adapter with DHCP enabled?

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #21291

    Robert
    Participant

    Hi Sangeeth,
    Thanks for the information. It will help others on this forum who have windows 7 and vmplayer setups.

    Regards,
    Robert

    Collapse
    #21290

    Hi Robert,

    That is an interesting question! I tried bringing up other VMs using the same VMplayer with Host-only n/w adapter but they all had the same problem – not able to obtain an IP address for the Host-only eth interface.

    After looking around for while, I was able to find out whats going wrong. In order to have the DHCP enabled for the VMs we need to first enable the “VMware Network Adapter VMnet”. On Windows 7, this is usually located in Control Panel >> Network and Internet >> Network Connections >> VMware Network Adapter VMnet.

    Right click on “VMware Network Adapter VMnet” >> “Properties” >> “Configure” >> “Enable”

    Now I see the sandbox (and other VMs) booting up fine without any issues!

    It would be great to have these information included in the installation manual. Perhaps in the FAQs?!

    Thank you!

    Collapse
    #21289

    Robert
    Participant

    Hi Sangeeth,
    Hmm, that seems interesting. I will check on my end if I get the same behavior. Just wondering, have you been able to bring up any other vm’s on that same vmware player where the network got an address for host only adapter?

    Regards,
    Robert

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)