The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Install Failure

  • #13794

    I have tried an install unsuccessfully twice now despite diligently following the installation instructions on the ‘automatic’ install path. This is a single-node CentOS 6.2 virtual machine environment.

    I get up through the ambari-server start step and everything has worked fine. When I go to the browser to login, though, all I get is a two pane screen where the top says ‘…Loading…’ and the bottom says: ‘Licensed under the Apache License, Version 2.0.
    See third-party tools/resources that Ambari uses and their respective authors’. Have tried all the usual sanity checks – stop/start of ambari-server, reloading page, etc.

    Any help is appreciated – I am thoroughly stuck other than starting down the Manual install path and hoping for a better outcome.

  • Author
  • #13798
    Sasha J

    I suggest you to look to ambari-server.log and see if there any clues for the problem.
    Also, try to use different browser. Ambari works fine with firefox, Chrome and Safari, but it may have some problems with IE…

    Thank you!


    I checked the ambari-server.log and .out files and there wasn’t any obvious indication of a problem.

    I had been using Firefox but from centos on the machine where I was installing. Your post triggered me to try logging in from a browser on another machine (now Firefox on Windows 7) and it was successful. Something about Firefox on centos is not working – maybe a missing plugin of some kind??


    Hi Bob,

    It could also be due to the deal that the version of firefox that is installed on CentOS by default is not the latest version.



    Getting farther, but still not success. I try to add my node but the registration comes back as failed – I am positive passwordless ssh is set up correctly (evident from log files). The log files are too big to post here, but look relatively normal down to the point where lots of packages are missing (see excerpt below). I have looked through logs in ambari-server, ambari-agent, and the bootstrap directory under /var/run/ambari-server. The only outright errors I see are these from the .log file in the bootstrap directory:
    tput: No value for $TERM and no -T specified
    tcgetattr: Invalid argument

    excerpt from the registration log:

    net-snmp: UNAVAILABLE
    net-snmp-utils: UNAVAILABLE
    puppet: UNAVAILABLE
    nagios: UNAVAILABLE
    ganglia: UNAVAILABLE
    passenger: UNAVAILABLE
    hadoop: UNAVAILABLE
    yum_repos: ok
    AMBARI-1.x Ambari 1.x 6
    HDP-UTILS- Hortonworks Data Platform Utils Version – HDP-UTILS-1. 52
    zypper_repos: UNAVAILABLE
    ‘, None)
    (” u’responseId’: 130,
    u’restartAgent’: False,
    u’statusCommands’: []}
    INFO 2013-01-18 11:17:58,618 – No commands from the server : []


    I tried to follow instructions in other threads for support. The bombs out because I have no /var/db/hmc/*. Assuming because my install didn’t make it that far.

    I uploaded ambari-server, ambari-agent, and bootstrap logs here to the ftp site as: wilki2021.logs.tar.gz


    I am still trying here. I rebooted and tried again and this seemed to help as I got past the registration step this time. Now I am stuck on installation. I see the server issuing execution commands from ambari-server.log like this:

    09:04:45,681 INFO ActionScheduler:285 – Scheduling command: {
    “commandType” : “EXECUTION_COMMAND”,
    “clusterName” : “mycluster”,
    “taskId” : 2,
    “commandId” : “1-1”,
    “hostname” : “bw-vm-3”,
    “role” : “GANGLIA_MONITOR”,
    “hostLevelParams” : {
    “jdk_location” : “”,
    “repo_info” : “[{\”baseUrl\”:\”\”,\”osType\”:\”centos6\”,\”repoId\”:\”HDP-1.2.0\”,\”repoName\”:\”HDP\”},{\”osType\”:\”centos6\”,\”repoId\”:\”HDP-epel\”,\”repoName\”:\”HDP-epel\”,\”mirrorsList\”:\”\\u003depel-6\\u0026arch\\u003d$basearch\”}]”

    I don’t see the agent ever get them though. The only thing in ambari-agent.log is an occasional registrationCommand and then heartbeats every 10 secs:

    INFO 2013-01-21 09:13:24,138 – Heartbeat dump: {‘componentStatus’: [],
    ‘hostname’: ‘’,
    ‘nodeStatus’: {’cause’: ‘NONE’, ‘status’: ‘HEALTHY’},
    ‘reports’: [],
    ‘responseId’: 1,
    ‘timestamp’: 1358781204112}

    That’s pretty much it for the log files. The server eventually times out the commands and reports failure.

    Any ideas or help is much appreciated.


    Hi Bob,

    Have you disabled SELinux? The fact that the ambari-agent was installed show the ssh is set up properly, also check to make sure that the firewall (iptables) has been shut off. To shut off iptables do this “service iptables stop” and “chkconfig iptables off”. To disable SELinux edit the file /etc/sysconfig/selinux, change the line “SELINUX=enforcing” to “SELINUX=disabled”. I mention this as from the bits of the logs you posted it looks like something is causing ambari-server and ambari-agent to not connect and these things are the most common cause of that disconnect.



    Yes – selinux is disabled and iptables are off. On a hunch, I tried something with the hostname that seemed to have made a difference. If you notice, the server log showed the unqualified hostname ‘bw-vm-3’ which is what I had entered for the node list whereas the agent log showed the fully qualified hostname ‘’. I went back through the install and entered the fully qualified hostname and now things seem to be progressing. Would obviously be nice if it could sort that out internally.

    Sasha J

    this is from installation documentation:

    In order to build up the cluster, the install wizard needs to know general information about how you want to set up your cluster. You need to supply the FQDN of each of your hosts.

    It explicitly says that you have to use FQDN for the host names….

    Thank you!

    Roger Hill

    Bob, I had this same issue …try using firefox instead of IE


    Hi Bob,

    Have you had a successful install while using the fully qualified names in the host list?


The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.