HDP on Linux – Installation Forum

Install hangs

  • #32895
    Member

    Hi I have three boxes. On one I have Ambari server running. Other two I have configured for nodes. I opted for manual install of agents on two nodes. I didn’t go the ssh route.

    0) I have RHEL 6 – 64 bit and downlaoded latest HDP 1.3

    1) running two agents on two nodes are fine.

    On Both Node
    ==========
    [root@rajesh]# ambari-agent start
    Verifying Python version compatibility…
    Using python /usr/bin/python2.6
    Checking for previously running Ambari Agent…
    Starting ambari-agent
    Verifying ambari-agent process status…
    Ambari Agent successfully started
    Agent PID at: /var/run/ambari-agent/ambari-agent.pid
    Agent outout at: /var/log/ambari-agent/ambari-agent.out
    Agent log at: /var/log/ambari-agent/ambari-agent.log

    On Server Box
    ============
    [root@rajesh]# ambari-server start
    Using python /usr/bin/python2.6
    Starting ambari-server
    Checking iptables…
    iptables is disabled now
    Running server: /usr/jdk64/jdk1.6.0_31/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Xms512m -Xmx2048m -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/sureskumar/bin:/usr/lib/ambari-server/* org.apache.ambari.server.controller.AmbariServer >/var/log/ambari-server/ambari-server.out 2>&1

    I am using the wizard to setup the Hadoop. I went till the 9th step Install, Start, Test.
    But it just starts and hangs at 3%.

    I have retried so many times. But it always hangs there. I dont knwo where to start debugging.
    I have been strugglign for almost a week. Can u pls help ?.

    Rajesh

to create new topics or reply. | New User Registration

  • Author
    Replies
  • #32905
    Member

    One more thing…I have not setup NTP between my windows(where the browser will ruin to access ambari server) and the three linux boxes. Is that an issue ?

    Is there a alternate, if I am not able to setup NTP between my windows and those three network boxes to install HDP 1.3 ?

    -Rajesh

    #32953
    Dave
    Moderator

    Hi Rajesh,

    If the installer is hanging about 3% I would check the hosts file for each of the boxes and ensure that you have all of the IPs for all your nodes and hostnames in each. Also be sure to include a localhost local in there too.

    So an example hostsfile for server1 would be:

    IP.address.server1 server1.hostname server1
    IP.address.server2 server2.hostname server2
    IP.address.server3 server3.hostname server3
    IP.address.server1 localhost local

    Let me know how you get on,

    Dave

    #33069
    Member

    Hi Dave,

    I am still having the issue.

    I am evaluating this Ambari approach for deploying Hadoop on large number of nodes for my company. A help would be really appreciated. If you need any details and info, let me know.

    thx
    -Rajesh

    #33072
    Member

    I have also noticed this error for various components in step 9

    none
    none

    Puppet has been killed due to timeout
    stdout:

    notice: Finished catalog run in 0.04 seconds
    notice: Finished catalog run in 0.04 seconds
    err: /Stage[1]/Hdp::Snmp/Hdp::Package[snmp]/Hdp::Package::Process_pkg[snmp]/Package[net-snmp-utils]/ensure: change from absent to present failed: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install net-snmp-utils’ returned 1: Error: Protected multilib versions: nss-3.13.3-6.el6.i686 != nss-3.13.6-2.el6_3.x86_64
    Error: Protected multilib versions: nspr-4.9-1.el6.i686 != nspr-4.9.2-0.el6_3.1.x86_64
    Error: Protected multilib versions: openssl-1.0.0-20.el6_2.5.i686 != openssl-1.0.0-25.el6_3.1.x86_64
    Error: Protected multilib versions: krb5-libs-1.9-33.el6.i686 != krb5-libs-1.9-33.el6_3.3.x86_64
    Error: Protected multilib versions: nss-util-3.13.3-2.el6.i686 != nss-util-3.13.6-1.el6_3.x86_64
    Error: Protected multilib versions: 1:net-snmp-libs-5.5-41.el6.i686 != 1:net-snmp-libs-5.5-41.el6_3.1.x86_64
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    err: /Stage[1]/Hdp::Snmp/Hdp::Package[snmp]/Hdp::Package::Process_pkg[snmp]/Package[net-snmp]/ensure: change from absent to present failed: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install net-snmp’ returned 1: Error: Protected multilib versions: nss-3.13.3-6.el6.i686 != nss-3.13.6-2.el6_3.x86_64
    Error: Protected multilib versions: nspr-4.9-1.el6.i686 != nspr-4.9.2-0.el6_3.1.x86_64
    Error: Protected multilib versions: openssl-1.0.0-20.el6_2.5.i686 != openssl-1.0.0-25.el6_3.1.x86_64
    Error: Protected multilib versions: krb5-libs-1.9-33.el6.i686 != krb5-libs-1.9-33.el6_3.3.x86_64
    Error: Protected multilib versions: nss-util-3.13.3-2.el6.i686 != nss-util-3.13.6-1.el6_3.x86_64
    Error: Protected multilib versions: 1:net-snmp-libs-5.5-41.el6.i686 != 1:net-snmp-libs-5.5-41.el6_3.1.x86_64
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    notice: /Stage[1]/Hdp::Snappy::Package/Hdp::Snappy::Package::Ln[32]/Hdp::Exec[hdp::snappy::package::ln 32]/Exec[hdp::snappy::package::ln 32]/returns: executed successfully
    notice: /Stage[1]/Hdp::Snmp/Hdp::Package[snmp]/Hdp::Package::Process_pkg[snmp]/Anchor[hdp::package::snmp::end]: Dependency Package[net-snmp-utils] has failures: true
    notice: /Stage[1]/Hdp::Snmp/Hdp::Package[snmp]/Hdp::Package::Process_pkg[snmp]/Anchor[hdp::package::snmp::end]: Dependency Package[net-snmp] has failures: true
    warning: /Stage[1]/Hdp::Snmp/Hdp::Package[snmp]/Hdp::Package::Process_pkg[snmp]/Anchor[hdp::package::snmp::end]: Skipping because of failed dependencies
    notice: /Stage[1]/Hdp::Snmp/Hdp::Snmp-configfile[snmpd.conf]/Hdp::Configfile[/etc/snmp//snmpd.conf]/File[/etc/snmp//snmpd.conf]: Dependency Package[net-snmp-utils] has failures: true
    notice: /Stage[1]/Hdp::Snmp/Hdp::Snmp-configfile[snmpd.conf]/Hdp::Configfile[/etc/snmp//snmpd.conf]/File[/etc/snmp//snmpd.conf]: Dep

    #33078
    Dave
    Moderator

    Hi,

    Do you only have 1 repository setup as it looks like you have a conflict of 32 bit and 64 bit libraries being pulled from yum.
    The error is being thrown here:

    Package[net-snmp-utils]/ensure: change from absent to present failed: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install net-snmp-utils’ returned 1: Error: Protected multilib versions: nss-3.13.3-6.el6.i686 != nss-3.13.6-2.el6_3.x86_64

    Which is a 32 bit library which should be x86_64

    Thanks

    Dave

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.