Home Forums HDP on Linux – Installation Install HDP on OEL 5.5 v1.0 ?

This topic contains 8 replies, has 2 voices, and was last updated by  Sasha J 1 year, 2 months ago.

  • Creator
    Topic
  • #14361

    Jeff Scott
    Member

    Is it possible to install HDP on Operating System : OEL 5.5 v1.0 – 64 Bit?

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #14522

    Sasha J
    Moderator

    Jeff,
    Ambari requires postgresql 8.x
    It does not support 9.0 as of today.
    You should resolve all the dependencies for 8.x in order to have Ambari installed an run.
    In general, if you have all the repositories configured correctly, ambari should resolve all the dependencies automaticaly and install all needed packages.

    Please, remove your manually installed postgres 9.0 and run “yum install ambari-server” again.
    Post all the error messages here.
    Make sure you set repositories correctly before running yum install…

    Thank you!
    Sasha

    Collapse
    #14521

    Jeff Scott
    Member

    To anwer Sasha’s question, I got the error:

    Error: Missing Dependency: postgresql-server >= 8.1 is needed by package ambari-server-1.2.0.1-1.noarch (AMBARI-1.x)

    Collapse
    #14520

    Jeff Scott
    Member

    Not sure where my last post went. I was not able to install Postgresql 8.x due to dependencies, but I was able to install, start, and initdb 9.0. However, when issuing the command “yum install ambari-server”, an error is returned saying it can’t find the postgresql-server service… 9.0 runs with a service name like postgress9.0-server. Can HDP run with Postgresql 9.0?

    Collapse
    #14465

    Sasha J
    Moderator

    Jeff,
    you should not install anything manually…
    postgres should be installed automatically as a dependency for Ambari server.
    What is the problems in installing it?
    Why you install postgres manually?

    Thank you !
    Sasha

    Collapse
    #14463

    Jeff Scott
    Member

    I was unable to install Postgresql 8.x but was successful installing 9.0. Unfortunately, the ambari-server setup seems to be looking for a service called “postgresql” while 9.0 runs as “postgresql-server-9.0″ Is there a way for it to to use 9.0?

    Collapse
    #14366

    Sasha J
    Moderator

    You should have system repositories configured and accessible.
    Or, you can install postgres manually if you like.
    Also, make sure names are correctly resolved for your nodes.

    Thank you!
    Sasha

    Collapse
    #14364

    Jeff Scott
    Member

    I’ll let you know. I am getting an error installing from the instructions at:

    http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-1.2.0/bk_using_Ambari_book/content/ambari-chap2.1.1.html

    Step 2.1.1.3 Running the Installer/Set Up the Bits/1.1. RHEL/CentOS 5.x/Install the Ambari bits using yum. This also installs PostgreSQL:

    yum install ambari-server

    Error: Missing Dependency: postgresql-server >= 8.1 is needed by package ambari-server-1.2.0.1-1.noarch (AMBARI-1.x)

    Collapse
    #14362

    Sasha J
    Moderator

    Jeff,
    OEL means Oracle Enterprise Linux, right?
    It is not officially sup[ported, but as it based on RedHat installation may be successful.
    I just made successful 3 node install on Scientific Linux, which is also RedHat based and not officially supported.

    Please, try it, and let us know about the results.

    Thank you!
    Sasha

    Collapse
Viewing 8 replies - 1 through 8 (of 8 total)