Home Forums HDP on Linux – Installation Install using Ambari

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  tedr 1 year, 7 months ago.

  • Creator
    Topic
  • #16516

    bruno bonnin
    Participant

    Hello,

    I am installing HDP using Ambari and I have a problem between the Amabri-server and the nodes to be configured.
    During the registration step, the node is trying to get the certificate (via the url http://:8440/cert/ca) and the ambari-server never respond to that request.
    Iptables is off and I can ping the server.
    When I try to connect to http://:8440/cert/ca using curl, the connection is made, but there is no response from the server too.

    Is there any specific configuration to do on the ambari-server and/or the nodes with the agents ? such as keystore to
    install, …

    Thanks for any help !

    Bruno

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #16815

    tedr
    Member

    Hi Bruno,

    It is great to hear that it is working now.

    Thanks,
    Ted.

    Collapse
    #16797

    bruno bonnin
    Participant

    Hi Ted,

    I think you are right : I have patched my ambari server with what it is described in the jira you have mentionned and it works !! Ambari Agent receive responses from the ambari server.

    Thanks a lot !

    Collapse
    #16785

    tedr
    Member

    Hi Bruno,

    Is your cluster on hardware or virtual? How much memory does each node have? It looks like you may be running into an issue we recently noticed: https://issues.apache.org/jira/browse/AMBARI-1432
    The fix for which will be in an upcoming patch release.

    Thanks,
    Ted.

    Collapse
    #16776

    tedr
    Member

    Hi Bruno,

    Could you give us the following information:

    OS and version
    /etc/hosts file from all nodes
    output of "hostname -f" on all nodes

    Thanks,
    Ted.

    Collapse
    #16766

    bruno bonnin
    Participant

    Hi,

    I have also disabled SELinux on all nodes.

    Bruno

    Collapse
    #16765

    tedr
    Member

    Hi Bruno,

    You mention that you have iptables turned off, have you also disables SELinux on all nodes?

    Thanks,
    Ted.

    Collapse
    #16723

    bruno bonnin
    Participant

    Hello,

    I have checked my configuration : I am using the FQDN.
    I have read the file NetUtil.py and the agent is blocked in the checkURL function at the line response=ca_connection.getresponse() . I have no log of success, nor error


    try:
    parsedurl = urlparse(url)
    ca_connection = httplib.HTTPSConnection(parsedurl[1])
    ====HERE=====
    ca_connection.request("GET", parsedurl[2])
    response = ca_connection.getresponse()
    ====HERE======
    status = response.status
    logger.info("DEBUG: Calling url received " + str(status))

    if status == 200:
    return True
    else:
    return False
    except Exception, e:
    logger.info("Failed to connect to " + str(url) + " due to " + str(e))
    return False

    Collapse
    #16518

    Sasha J
    Moderator

    Bruno,
    Make sure you use FQDN, not the short names.

    Sasha

    Collapse
    #16517

    bruno bonnin
    Participant

    Oops ! in my post, the URL of ambari-server is, of course, something like : https://myhost:8440/cert/ca

    Collapse
Viewing 9 replies - 1 through 9 (of 9 total)