The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Installation fails on starting namenode

  • #13390
    Niels Basjes


    I’ve been trying to install HDP 2 on a few old desktop systems to see what it the differences are with CDH.
    I use CentOS 6 64bit and after having installed it all the Ambari gui shows it failed during the startup of HDFS.
    After some searching I’ve found the actual error:

    “\”Thu Jan 10 12:33:18 +0100 2013 /Stage[2]/Hdp2-hadoop::Namenode/Hdp2-hadoop::Service[namenode]/Hdp2::Exec[su – hdfs -c ‘/usr/lib/hadoop/sbin/ –config /etc/hadoop/conf start namenode’]/Exec[su – hdfs -c ‘/usr/lib/hadoop/sbin/ –config /etc/hadoop/conf start namenode’]/returns (notice): log4j:ERROR Could not find value for key log4j.appender.RFAS\””,
    “\”Thu Jan 10 12:33:18 +0100 2013 /Stage[2]/Hdp2-hadoop::Namenode/Hdp2-hadoop::Service[namenode]/Hdp2::Exec[su – hdfs -c ‘/usr/lib/hadoop/sbin/ –config /etc/hadoop/conf start namenode’]/Exec[su – hdfs -c ‘/usr/lib/hadoop/sbin/ –config /etc/hadoop/conf start namenode’]/returns (notice): log4j:ERROR Could not instantiate appender named \\\”RFAS\\\”.\””,

    So I added these extra lines to /etc/hadoop/conf/
    log4j.appender.RFAS.layout.ConversionPattern=%d{ISO8601} %p %c: %m%n

    Now when I run this command (manually) I get this error in the logfile: NameNode is not formatted.

    Now I know how to do things like that but Ambari only offers to reinstall the cluster and start over (well I tried that a few times and it doesn’t work).

    I have two questions:
    1) Are these above points simply “known bugs” in the installation?
    2) How do I continue the installation after I’ve fixed the underlying error (like I did above)?

    Niels Basjes

  • Author
  • #13394
    Larry Liu

    Hi, Niels,

    Thanks for trying HDP.

    From the error you get “ NameNode is not formatted.”, it seems the Namenode is not formatted successfully during HDFS startup. Can you please get the log files from /var/log/hadoop/hdfs and ftp to us:

    In order to continue, you may try to format by running the following command as root:

    su – hdfs -c “/usr/lib/hadoop/bin/hadoop namenode -format”

    Hope this helps.


The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.