Home Forums HDP on Linux – Installation Installation via Ambari fails

This topic contains 5 replies, has 2 voices, and was last updated by  tedr 1 year, 2 months ago.

  • Creator
    Topic
  • #29409

    NotAgain
    Member

    Hi Everyone,

    This is my first Post. Sorry that it will be regarding some issues I am facing.
    (Because of the Issues I am facing I am going to use the SandBox version for the time being)

    Here is what I wanted to do:

    -Create 3 Virtual Machines (Using VirtualBox) and install CentOS 6 (64 bit ofcourse). The Virtualization is enabled in the BIOS BTW.
    -Let the names be centos1,centos2 and centos3.
    -Create a cluster using Ambari across the three machines.

    What I did:
    1. Created a dedicated group called Hadoop(On each machine).
    2. Create a dedicated user called “hduser” and added it to “Hadoop” (On each machine).
    3. Added “hduser” to sudoer’s list and configured “NOPASSWD” for it in the file (On each machine).
    4. Created the password-less SSH login across the three machines for this user(On each machine).
    Doing : ssh hduser@centos1
    Is actually logging me into “centos1″ machine without asking for any password.

    Then I followed the steps given in the Automated install. Obviously I am doing something wrong. Because it failed for me.

    Here are my questions:
    1. Fully Qualified Domain Name:
    What is really meant by this?
    I added to my /etc/hosts:

    192.123.45.123 centos1
    192.123.45.124 centos2
    192.123.45.125 centos3

    My “/etc/sysconfig/network” on centos1 machine is:
    NETWORKING=yes
    HOSTNAME=centos1
    And similarly for other machines the HostName varies.

    Then I had the issues in Install regarding FQDN. I came across this link : http://stackoverflow.com/questions/9541460/httpd-could-not-reliably-determine-the-servers-fully-qualified-domain-name-us
    Where it is mentioned “For example, the following is a valid FQDN: host.server4-245.com”

    If this is indeed the case then can this be added to the Install Steps.

    2. I changed the /etc/hosts and “/etc/sysconfig/network” on each hosts to contain dummy hostnames. Are these ok now?

    I added to my /etc/hosts:
    192.123.45.123 centos1.helloworld.com
    192.123.45.124 centos2.helloworld.com
    192.123.45.125 centos3.helloworld.com

    My “/etc/sysconfig/network”
    NETWORKING=yes
    HOSTNAME=centos1.helloworld.com
    Rebooted the machines. Hostname -f now shows “centos1.helloworld.com”.

    3. Now I am getting “Cluster primary OS type is centos6 and local OS type is centos6″. :(

    Few more questions on install process:
    1. “Disable iptables” – Do it on all Nodes or just the machine where I will start Ambari Server?
    2. “Disable PackageKit” – Same question as above.
    3. “Check umask Value” – Same question as above.
    4. The whole install(yum install ambari-server) of Ambari Server happens on “root” login. And so does the setup (ambari-server setup). Right?
    5. “ambari-server start” Does this also have to be under “root” login? I will rather have it that the “hduser” starts and stops it.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #29584

    tedr
    Moderator

    Hi NotAgain,

    It looks like you need to reset the Ambari database. You do this with ‘ambari-server reset.’ this should clean out the db that ambari uses. Then try installing again.

    Thanks,
    Ted.

    Collapse
    #29563

    NotAgain
    Member

    Hi,
    Thanks for clarification.
    But I still see the errors.

    I followed what was mentioned in one of the posts:
    Try the following steps:
    On the master node
    ambari-server stop
    ambari-agent stop
    yum erase ambari-server
    rm -rf /var/lib/ambari-server
    yum install ambari-server
    yum erase ambari-agent
    rm -rf /var/lib/ambari-agent
    yum install ambari-agent
    ambari-server start
    ambari-agent start
    On each slave node
    ambari-agent stop
    yum erase ambari-agent
    rm -rf /var/lib/ambari-agent
    yum install ambari-agent
    ambari-agent start

    This took me a little bit further. On the host machine where the Ambari is supposed to run, I got success. But on the other two machines I got failures.

    I see this error in the agent logs of both the machines.

    INFO 2013-07-17 18:01:33,957 NetUtil.py:55 – Failed to connect to https://centos1:8440/cert/ca due to [Errno -3] Temporary failure in name resolution
    INFO 2013-07-17 18:01:43,971 NetUtil.py:55 – Failed to connect to https://centos1:8440/cert/ca due to [Errno -3] Temporary failure in name resolution
    INFO 2013-07-17 18:01:53,979 NetUtil.py:55 – Failed to connect to https://centos1:8440/cert/ca due to [Errno -3] Temporary failure in name resolution
    INFO 2013-07-17 18:02:03,992 NetUtil.py:55 – Failed to connect to https://centos1:8440/cert/ca due to [Errno -3] Temporary failure in name resolution
    INFO 2013-07-17 18:04:08,237 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2013-07-17 18:04:18,250 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2013-07-17 18:04:28,263 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2013-07-17 18:04:38,267 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2013-07-17 18:04:48,299 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2013-07-17 18:04:58,310 NetUtil.py:55 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused

    Somewhere it is still holding on to the earlier “centos1″ hostname instead of picking up the updated “centos1.helloworld.com” hostname.

    Still investigating.

    Collapse
    #29423

    tedr
    Moderator

    Hi NotAgain,

    The answers to your questions in order are: iptables, PackageKit must be disabled on ALL nodes; umask value needs to be checked on all nodes; install, setup, and start of ambari-server currently need to be done as ‘root.’ Or at least as someone with root privileges. I you are using a user with sudo privileges you need to preface each of the commands with ‘sudo’, you can even do so for the ‘yum install…’. The configuration of you /etc/sysconfig/network and /etc/hosts looks correct as long as all 3 are done similarly, as all there need to be referred to by the FQDN. Also make sure that you have set up passwordless ssh from the host you are running ambari-server on (centos1) to itself as well as to all other boxes.

    Thanks,
    Ted.

    Collapse
    #29411

    NotAgain
    Member

    Groan. I am messed up. I will update the correct error message once I reach home. :(

    Collapse
    #29410

    NotAgain
    Member

    EDIT: “Cluster primary OS type is centos6 and local OS type is centos6″ is something like
    “Cluster primary RedHat type is centos6 and local OS type is centos6″. I will update once I reach home.

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)