Home Forums Hortonworks Sandbox IP 127.0.0.1:8888 in place of 192.168.56.101

This topic contains 6 replies, has 5 voices, and was last updated by  Sasha J 1 year, 1 month ago.

  • Creator
    Topic
  • #30392

    After I installed Sandbox 1.3 on Oracle VirtualBox 4.2… (all happening on OS X 10.8.6) I it suggested to connect on http://127.0.0.1:8888 and ssh on 127.0.0.1:2222. Neither works.
    I have the followings network settings:

    Hortonworks Sandbox: Settings -> Network
    Adapter 1 – Enabled, NAT
    Adapter 2 – Enabled, Host-only Adapter, vboxnet0
    (I tried to switch adapter 1 and 2 settings, no joy)

    VirtualBox -> Preferences -> Network vboxnet0
    If click on the screwdriver icon – DHCP server disabled.

    Please help/
    Thank you
    Alexey Yakubovich

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #31149

    Sasha J
    Moderator

    People,
    let us not mix different hypervisors in the same thread….
    It works slightly different.

    Fo VirtualBox and VMWare Fusion/Player no need to change any network settings.
    It works out of box with no problems.

    For Hyper-V setup, follow mentioned post:

    http://hortonworks.com/community/forums/topic/sandbox-1-3-hyperv-support-better-vbox-support-32-bit-os/

    Thank you!
    Sasha

    Collapse
    #31060

    Jose Chinchilla
    Participant

    A better accepted approach is to change the IP Address of the virtual switch named vSandbox to an IP in the same subnet. I changed the vSandbox IP to 192.168.56.100 Subnet Mask: 255.255.255.0 Gateway: none

    This forum thread explains the solution:

    http://hortonworks.com/community/forums/topic/sandbox-1-3-hyperv-support-better-vbox-support-32-bit-os/

    Collapse
    #31055

    Jose Chinchilla
    Participant

    I had to change the IP address to an IP address in my subnet:

    I used the following commands:

    Access network settings file: # nano /etc/sysconfig/network-scripts/ifcfg-eth0

    Restart network service :# service network restart

    Change DNS settings file: # nano /etc/resolv.conf

    Collapse
    #30528

    Cheryle Custer
    Moderator

    Krati,

    Once you have installed the VM, open a new browser window and type in the IP address with the full http://127.0.0.1:8888 in the browswer address bar.

    Collapse
    #30527

    Cheryle Custer
    Moderator

    Alexy,

    Please remove the Virtual Machine and re-import. Do not change the Network Adapter settings — allow the default settings to remain. This should allow you to connect using the suggested IP address. In the 1.3 version of the Sandbox we refined the installation and import process and you should be able to use the default settings.

    Cheryle

    Collapse
    #30441

    Krati Singh
    Member

    Facing same issue on VMware WM. How to launch browser from VM? Also, once launched what is the URL to be typed in browser? Please help. Thanking in anticipation!!

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)