Home Forums Hortonworks Sandbox IP Address in Virtual box points to 127.0.0.1:8888

This topic contains 6 replies, has 6 voices, and was last updated by  Chirag Shah 10 months, 2 weeks ago.

  • Creator
    Topic
  • #27500

    K S
    Member

    Hi there

    I have been trying to connect to sandbox and am getting this message when Sandbox is ready and running in virtualbox:

    Connect to virtual box via browser using 127.0.0.1:8888 and using this IP I was unable to connect to the sanbox via Chrome browser.

    I logged into the virtual box and found my eth0 was set to 192.168.157.101 and I tried connecting to this IP address but same results – Chrome could not connect to it.

    My network adapter is set as per instructions:
    1. Host only – DHCP enabled
    2. NAT

    I can ping the sandbox on eth0 IP but can not connect via browser. Am using Windows7 , 64 bit machine.
    Any pointers to solve my issue would be greatly appreciated.

    Cheers
    KS

Viewing 6 replies - 1 through 6 (of 6 total)

The topic ‘IP Address in Virtual box points to 127.0.0.1:8888’ is closed to new replies.

  • Author
    Replies
  • #39432

    Chirag Shah
    Member

    Hi,

    I faced same problem then I changed Host-only Adapter to NAT and it worked. Thanks for helping.

    Regards,
    Chirag Shah

    Collapse
    #27815

    Sasha J
    Moderator

    Alastair,
    Please, ignore this documentation paragraph…
    It is incorrect and shopuld be removed.
    Bug filed for this issue.
    Thank you for poiunting this out and for using Sandbox!

    Thank you!
    Sasha

    Collapse
    #27811

    The folowing paragraph in the installation instructions appears to be wrong:

    In general, the default settings for the environments are fine. The one item that
    you may need to set up is the Network Adapter. To use the Sandbox, you should
    have a Host-only network adapter with DHCP enabled. This ensures that the
    host machine and the virtual machine can talk to each other, which is necessary
    for the Sandbox to work. Setting up this adapter is covered in the detailed
    installation instructions.

    It was only by reverting to the default single Network Adapter attached to NAT that I got the 127.0.0.1:8888 address to work.

    Collapse
    #27638

    tedr
    Moderator

    Hi K S,

    thanks for the info of how you got it working.

    Thanks,
    Ted.

    Collapse
    #27590

    K S
    Member

    Thanks Carter

    That was helpful.
    Here’s a little summary of how I got connected to sandbox.
    1. I am running Virtualbox 1.3
    2. Imported sand box (VB version) and did not make any change in the settings.
    3. I have 1 NIC enabled (NAT) and it was created by default.
    4. After the sandbox gave me IP to connect (http://127.0.0.1:8888/), I went ahead and connected via Chrome. This time it worked !
    5. Am now moving ahead in my journey trying to get ODBC connectivity to sandbox .

    Hope this helps those who are still struggling to connect to sandbox via browser.

    Cheers!
    KS

    Collapse
    #27508

    Carter Shanklin
    Participant

    KS, There may have been some confusion with documentation versions. With sandbox version 1.3 you should only have 1 NIC card. It’s probably easiest to re-import the OVA and start over.

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)