Home Forums Hortonworks Sandbox IP address reported in Sandbox display not correct for ssh

This topic contains 14 replies, has 7 voices, and was last updated by  James Solderitsch 1 year, 5 months ago.

  • Creator
    Topic
  • #19422

    Things were all going well. Except VMware player was nagging me to update to the latest 5.02 version. So I did. But now networking is messed up.

    Basically the local IP that the Sandbox display tells me to use is 192.168.198.129 but I can’t connect to that via ssh. So I logged into the Sandbox and it reports eth0 and eth1 are active. eth1 is the one with this address. eth0 has another address: 192.168.150.132.

    This second address DOES work via ssh.

    I have two network adapters in the VMware configuration for this machine. The first is set to NAT, the second to Host-Only which according to the Sandbox install instructions seems like what you want.

    Why is the sandbox reporting the wrong local IP to use to access it? Any way to fix this short of re-importing the machine (starting from scratch)?

    Thanks

    Jim

Viewing 14 replies - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #26735

    Yes, it seems that when I updated player from 5.0.1 to 5.0.2 without first removing the old version, some network plumbing got fouled up. It was only recently that I saw that one of network adapters VMNET1 and VMNET8 wasn’t correctly configured. My problems with ssh IP addresses began only after the upgrade and I had been living with them for awhile.

    So I deleted the current 5.0.2, did a fresh install, and then my IP issues went away and I checked that both of the network adapters seemed to have correct assigned IPs. So connecting the dots, it seems like the player upgrade was the source of the problem.

    Collapse
    #26734

    tedr
    Moderator

    Hi James,

    Thanks very much for this useful information. If I’m understanding it correctly this problem was due to a VMware problem and not really a Sandbox problem then, correct?

    Thanks,
    Ted.

    Collapse
    #26689

    Wanted to update this thread. On the Windows PC where the problem surfaced, I continued to have trouble accessing the VM through the announced IP in the VM window and had to login and find the NAT address and use that.

    Turns out that my VMNET1 interface was not showing a proper IP address — this is the one supporting the Host-only IP that the sandbox tells the user is the right one whereas VMNET8 was showing a proper address and this was for the NAT address.

    My fix for this was to uninstall VMware player, download a fresh installer for 5.0.2 Player, and re-install. Then I used ipconfig in Windows to inspect the addresses for VMNET1 and VMNET8 and both were properly formed. On the next reboot of the VM, I could use the IP that the running VM screen says I should use which is the Host-Only IP.

    Hope this might help folks who continue to have connectivity errors with the Sandbox and VMware Player.

    Collapse
    #22118

    tedr
    Member

    Hi Waly,

    Thanks for letting us know of how you got the Sandbox on VMware working.

    Thanks,
    Ted.

    Collapse
    #22087

    Waly Ndao
    Participant

    Hi guys,

    I had the same issue with the Sandbox on vmware. The ip address displayed after setup was not working, so I used the ip address for eth0 which worked. This solution is not practical however, as pointed by Celia.

    Here is what I did to get it working. I added a second network adapter for the VM, and set it to NAT instead of Host-only. So the VM has two network adapters that are both set to NAT. I don’t know whether this is bad practice, but it solved the issue. Just thought I would share it here. Hope it helps.

    Thanks

    wkn

    Collapse
    #20575

    Seth Lyubich
    Keymaster

    Hi Celia,

    Can you please let us know if your Sandbox ever worked? Also did this happen after upgrade? Can you also let us know what you get when you enter Sandbox through command line and run:

    #netstat -anp|grep 8888

    if service listens on 0.0.0.0 it could be that the issue is due time out. Increasing VM memory might help with this.

    I also was not able to reproduce the issue in VM player. I tried VM player upgrade, and even reversed order of NAT and Host only interface in appliance. Even then Sandbox worked with no issues. Please let us know if you have other details that might be helpful for us to reproduce the issue.

    If possible you can try importing appliance one more time and see if that will fix the issue.

    Thanks,
    Seth

    Collapse
    #20471

    Celia Muriel
    Member

    Yes, Robert, I tried.

    Collapse
    #20384

    Robert
    Participant

    Hi Celia,
    Have you simply tried restarting the VM to see if it resets the network?

    Regards,
    Robert

    Collapse
    #20346

    Celia Muriel
    Member

    Hi Ted,

    I’m using the VMWare version. And yes, I followed the instructions which comes with the VM.

    Cheers,

    Celia

    Collapse
    #20340

    tedr
    Member

    Hi Celia,

    Thanks for trying the Hortonworks Sandbox. Are you using the VMware or the Virtualbox version of the Sandbox? Also when you initially set up the vm did you follow the instructions for the “host only” networking and such?

    Thanks,
    Ted.

    Collapse
    #20293

    Celia Muriel
    Member

    Hello all,

    Whenever I load the Sandbox, I get next message:

    I had the same issue as James when trying to log into the browser, so I found the new IP address with ifconfig eth0, as he suggested in his post below. In my case, the new IP address was 192.168.44.128.

    When I navigated to http://192.168.44.128, the browser could find the address and enter in the Sandbox.
    If I click on the “Start” button under “Use the Sandbox”, I can see the portlet with Pig, Hive, etc.
    If I click on the “Start” button under “Run Tutorials”, I can see the portlet with the tutorials on the left. An error message appears on the right where the portlet with Pig, etc. should be. The error message says:

    <blockquote cite="This webpage is not available
    Google Chrome could not load the webpage because 192.168.179.128 took too long to respond. The website may be down, or you may be experiencing issues with your Internet connection.
    Here are some suggestions:
    Reload this webpage later.
    Check your Internet connection. Restart any router, modem, or other network devices you may be using.
    Add Google Chrome as a permitted program in your firewall’s or antivirus software’s settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.
    If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don’t believe you should be using a proxy server, adjust your proxy settings: Go to the Chrome menu > Settings > Show advanced settings… > Change proxy settings… > LAN Settings and deselect the “Use a proxy server for your LAN” checkbox.
    Error 118 (net::ERR_CONNECTION_TIMED_OUT): The operation timed out.”>

    Any idea where I can change the IP address on the portlets to point them to my new IP?

    I am using Google Chrome Version 26.0.1410.43 m, and Sandbox 1.2.

    Thanks,

    Celia

    Collapse
    #19760

    tedr
    Member

    Hi James,

    Thanks for the info. Will be sure to pass it along. I’m not sure that it matters which order the NAT/Host-Only are assigned to the cards, what matters is how the CentOS VM sees them. How the CentOS VM sees them is based on the MAC address that they are assigned, if they are given different MAC addresses then CentOS will assign them to different ethx cards. It will assume that the old “cards” are no longer in the box and assign them a new interface number. This can be changed to get them back to eth0 and eth1, but the process is a bit long to describe here.

    Thanks,
    Ted.

    Collapse
    #19425

    I did reboot both the Host and the VM after updating the player. When things weren’t working after that, with the Sandbox VM shut down, I deleted both network adapters, added new ones in, made the first one be the NAT adapter and the second the Host-Only adapter, started the VM and still the wrong IP reported. This was the order of the network interfaces all along I think, but maybe I have the order wrong? Does it matter?

    This is when I decided to login to the VM from the VMware console and see what ifconfig reported and that led me to discover the IP address that would allow ssh to connect — the one belonging to eth0.

    Hope this helps in future when people report IPs not working.

    Collapse
    #19424

    Seth Lyubich
    Keymaster

    Hi James,

    Can you please check to make sure that host-only and NAT interface configuration is the same as prior to update? Can you please check if any settings got changed?

    Also, did you try rebooting VM and host machine after update?

    Hope this helps.

    Thanks,
    Seth

    Collapse
Viewing 14 replies - 1 through 14 (of 14 total)