The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

Issue connecting Talend studio with Sandbox

  • #29739

    Hi Team,
    I have tried connecting Talend with Sandbox based on the documentation provided in the HortonWorks. I have just tried using the tHDFSPut on a sample job created . Once i execute the job as per the documentation it is expected to create a file under “user/hue” directory . When i executed the job it created a file in the user/hue directory with 0 byte size. The talend execution console shows the following exception. Please help.
    Starting job SampleJob2 at 23:19 20/07/2013.
    [statistics] connecting to socket on port 3635
    [statistics] connected
    13/07/20 23:20:27 INFO hdfs.DFSClient: Exception in createBlockOutputStream Connection timed out: no further information
    13/07/20 23:20:27 INFO hdfs.DFSClient: Abandoning block blk_-3874851192982451386_1670
    13/07/20 23:20:27 INFO hdfs.DFSClient: Excluding datanode
    13/07/20 23:20:27 WARN hdfs.DFSClient: DataStreamer Exception: org.apache.hadoop.ipc.RemoteException: File /user/hue/data.txt could only be replicated to 0 nodes, instead of 1
    at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getAdditionalBlock(
    at org.apache.hadoop.hdfs.server.namenode.NameNode.addBlock(
    at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.apache.hadoop.ipc.RPC$
    at org.apache.hadoop.ipc.Server$Handler$
    at org.apache.hadoop.ipc.Server$Handler$
    at Method)
    at org.apache.hadoop.ipc.Server$
    at org.apache.hadoop.ipc.RPC$Invoker.invoke(
    at $Proxy1.addBlock(Unknown Source)

  • Author
  • #29774
    Sasha J

    THis error means that you have problems with HDFS.
    Most likely DataNode process is not running or disk is full.
    HDFS can not create file.
    Restart your Sandbox and make sure you did not fill up it’s disk.

    Thank you!


    Hi Sasha,

    Thanks for your analysis and response.
    I have verified the disk and its not full. All the input files used for tutorials where cleared from user directory before attempting to connect Sanbox with talend studio . Also the Sanbox was restarted multiple times.
    Could you please let me know how to verify or confirming that the data node in a sandbox environment is running or not. Only during the launch and booting of sandbox environment I could find that servers and nodes are started and running. Once it’s started I am not able to find any options in any dashboards to verify the status of datanode.
    I tried with the basic tutorials provided along with the sandbox which are working fine. So I think the datanodes are functioning properly. When I tried connecting the sandbox with talend studio I was getting the exception in talend log console as mentioned in my earlier posting. Please let me know any additional information I could share from my end that could be helpfull for resolving this issue.

    Awaiting your response . Thank you.

    Rupesh Dandekar

    I’m getting the same error. HDFS is not full and working fine with tutorials.


    Hi guys,
    I am just wondering if from your machines you can telnet to I assume from the hue interface all is working with uploading files to hdfs. Can you guys verify the port is accessible from your client machine?


    Kai Waehner

    Same problem here with Sandbox 1.3. Disc is not full. Hortonworks tutorials work perfectly.

    I had it working with Talend and Sandbox 1.2. Tried with same configuration here. I only changed the IP addresses (was in 1.2, now it is in 1.3)

    Probably, this is a configuration issue ?!

    Kai Waehner

    Btw: Now, I am using Virtual Box image. Before, I used a VMware image which I converted to Parallels…


    I tried using sandbox HDP 1.3 with talend studio to write a file into hadoop . I was using hortworks data platform 1.0 library from the drop down in the talend studio connection as I was not able to see another library version of horton works. For HDP 1.3 . When it tried executing the file was generated inside hadoop folder but the file was empty and. An exception was thrown in talend studio log . As per the tutorial the file was suppose to generate with some rows entered .

    Does anyone successfully excecuted this scenario ? I used hdfs:// / to connect to hadoop. I
    is thre any library available for talend studio to execute against HDP 1.3 .?



    I have the same issue, Talend is creating a 0 byte file in the hdfs


    Same problem. Does anyone have a solution to this?

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.