The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

Issues installing Sandbox on VMWare player

  • #53647
    Matthew Potter


    I’m very new to vmware, hadoop and all this stuff coming from more of a .NET background, but wanted to evaluate the technology and try it out.

    First of all I have installed VMWare player 6.0.2 build-1744117 on a Windows 8.1 4GB Asus laptop, downloaded the Hortonworks_Sandbox_2.1 ova file.

    It all loads up correctly apart from an error:

    Call From failed on connection Connection refused

    I don’t know if this is important or whether it is a showstopper, but it didn’t look good to me.

    It seems to work up to a point. The load of the VM works and I can load up the “Welcome to the Hortonworks Data Platform (HDP) 2.1 Sandbox” page, but when I click on the “Dive right in” link on the page I just get an Unable to access network error:

    Google Chrome is having trouble accessing the network.

    This may be because your firewall or anti-virus software wrongly thinks Google Chrome is an intruder on your computer and is blocking it from connecting to the Internet.
    Allow Chrome to access the network in your firewall or antivirus settings.
    If it is already listed as a programme that is allowed to access the network, try removing it from the list and adding it again.

    I have also tried firefox, but get a similar error.

    I’ve tried opening the ports used, disabling the firewall, but this seems to have no effect.

    I also tried ssh root@ but it just seems to hang (I’ve also tried with the -v switch and it seems to connect, but hangs and doesn’t return to the user).

    I’d prefer to get the browser UI working if possible, but if not at least the command line.

    Any help would be much appreciated from a newbie.



  • Author
  • #53665
    Matthew Potter

    In case anyone is reading this – I’ve just installed VirtualBox and downloaded the HDP Sandbox for VirtualBox and although I got the same output logged it works. I’d love to know why. Maybe the HDP Sandbox for VMWare I downloaded was corrupted somehow, or maybe the VMWare Player wasn’t installed correctly. I’ve looked around the web everywhere, but found no advice anywhere, which is a little worrying for a product that is supposed to be cutting edge.


    Hi Matthew,

    The error looks to be coming from VMWare as opposed to HDP itself.
    If you used you probably would’ve been able to connect.
    This is to do with the network settings in VMWare Player, desktop whichever you are using.

    I can assure you the Sandbox for VMWare does work and if you setup the correct networking dependent on your hardware (I usually used bridged and that way I can access it anywhere on my network)



    Matthew Potter

    Hi Dave,

    Thanks for your response. It is much appreciated. I’ve tried changing to use NAT, Bridged, Host Only and anything else I can think of and it still doesn’t seem to work. You say you use bridged, but it doesn’t mention this anywhere I’ve read.

    I posted this so if anyone hit this problem they’d have some answers. Just to note I downloaded VirtualBox and on the first download of the ova file it didn’t downloaded completely and it didn’t even get to the stage of returning the page with the links to the tutorials and hue interface (and the filesize is as it says it should be).

    It’s just frustrating that there is nothing out there. I know these things can be tricky as I’m guessing other things on the PC can interfere with this or maybe in Windows 8.1 or the firewall/virus protection that is blocking it from working. It’s interesting it works in VirtualBox but not VMWare though.

    The other thing is that there is a pdf install guide for Mac but not Windows.

    I had previous tried to install hadoop natively using Java, cygwin, Maven, and Protocol buffers, but couldn’t get it working and gave up after reading and trying advice found online. I do seem to have 2 Network adapters for VMWare visible on the Network and Adapter page in Control Panel. I don’t know if this is causing a problem. As I said before there isn’t much advice out there.

    Any comments let me know. It was just getting really frustrating.




    Hi Matthew,

    This is just my personal preference.
    Obviously if you used bridged then you will not be able to connect to (ie localhost) as you will need to use whatever IP the sandbox gets. Ie on my network it is a 192.168.1 address.
    Virtual Box will be setup with different defaults to VMWare – we can’t control how your virtualization software is configured.
    The PDF guide for the mac is basically the same as windows:

    Open VMWare player, click on import. Or double click on the VMWare machine.

    You could create a VMWare machine with CentOS on it and configure the networking and install a single node cluster if you wanted it to be fully reachable from within your network.

    The Sandbox does work if you SSH into it and ensure it is listening on the correct ports – this is where you Virtualization software comes into it.
    I would look at VMWare documentation if you are not familiar with the settings – otherwise I am happy to help.



    Jamal Kazmi


    I am encountering exactly the same issue using VMWare. I am using Sandbox version 2.1. I would greatly appreciate some help. When the sandbox starts using NAT or bridged the sandbox isn’t available at

    I even tried to use ssh but VMWare simply hangs and doesn’t respond to the SSH command. At this point I am unable to evaluate HortonWorks. Please advise.


    I am also getting same issue of connection refused any one succedded with windows 7 ?
    I m using router does it matters please help
    I am not able to connect to GUI through browser 127.0 .0 .1:8000

    Rajesh Mhatre

    I am able to connect to sandbox 2.1 via IE9 this page asks to register for sandbox and then navigates to the tutorials page.
    But I am not able to connect web UI ( can any one help me on this ????

    Some guide may help me to greater extend.

    Arthur Coleman

    I have the same problem with the V2.2 Preview Sandbox on Windows 8 using VMWare Player (Free) V7.0.0 . I can log into the VM no problem, I can ssh into the VM and run Hive no problem, but cannot get into the browser-based UI at http://192.168.18:8000, which is the link provided.

    I also tried connecting to that did not work either.

    The exact error I received on starting the sandbox was a warning around zookeeper starting:

    “Using config: /etc/zookeeper/conf/zoo.cfg
    safemode: Call from to failed on connection exception: Connection refused: For more details see:

    Looked at all the posts, and the only thing I haven’t done is changed networking to bridged mode as I am no expert at networking and don’t see below that it specifically solved the problem.

    Look forward to anyone else’s thoughts on what might work.

    In the meantime, I’m enjoying the command line – it’s why I wanted to install my own instance anyway. Didn’t want to use the browser UI. So it is not holding up my work too much. It’s just annoying.

    Jay Tse

    I initiall had the exact same problem.
    This is how I solved it :
    1. When I installed VMWare Workstation 10 on Windows 7 64 Bit, it created several virtual network adapters –
    (a) VMware Network Adapter VMnet1 (in Networking properties, VMware Bridge Protocol is disabled)
    (b) VMware Network Adapter VMnet8 (in Networking properties, VMware Bridge Protocol is disabled)
    2. I had disabled these two adapters, hence it was not connecting. So Step 2 is to enable them
    3. I changed the Virtual Machine Setting for Network Adapter in WMware Workstation from NAT to Host-only: A private network shared with the host
    4. Hortonworks Sandbox 2.1 gave me “ which I entered into Firefox, and it worked
    Note: When using Host-Only Networking, don’t click/use the link. Instead, use http://<ip addr provided by your VM>:8000

    Hope this helps some people.

    pragyanshu kukreti

    i have downloaded and installed HDP2.2.4 on windows 8.1 pro hyper v but when connecting and starting it gives me this error, i am not even able to reach up to a point where it provides an ip address to open it on web browser

    safemode: Call From to failed on connection exception: Connection refused;
    For more details see:

    please help

    Ludovic Janssens

    Hi, I had an identical issue as Arthur Coleman on Windows 8. Did anyone find a solution to the network issue?


    Hi Ludovic,
    have you tried latest Sandbox HDP 2.3 build.


    akshay naidu

    I downloaded HDP 1.3 for VMware.
    now when I try to open it with VMware a message appears saying “failed to query for source information”.
    I am unable to find any discussion related to this problem anywhere.
    please someone help me here.

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.