Ambari Forum

Job History Web UI

  • #49080
    Sri Sushma K


    I am working on ec2-instances. IP tables are off on ambari master and two master slaves. I am able to access Ambari UI, NameNode UI but I am unable to accept JobHistory UI and logs on the second master node. PLEASE let me know what can be done because I do not find any logs in var/log/map-reduce/ !. Any help will be highly appreciated. Thank You

to create new topics or reply. | New User Registration

  • Author
  • #49103
    Kenny Zhang

    Hi Sri,

    Please make sure the mapreduce service is turn on and running. You can verify this by issuing the command “jps” on the second master node.

    If the services are up and running, please let us know what error you encounter on the web UI.

    Please also share the history server logs in:
    HDP 2: /var/log/hadoop-mapreduce/mapred/mapred-mapred-historyserver-xxx.log
    HDP 1: /var/log/hadoop/mapred/hadoop-mapred-historyserver-xxx.log


    Sri Sushma K


    1. jps command not found (but I can see mapreduce running on Ambari UI and can even run map reduce examples)
    2. The following is the error on Web UI

    The connection has timed out
    The server at is taking too long to respond.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

    3. This is the log in secondary master node. I do not see any logs first master node or slaves.
    2014-02-05 10:47:38,327 INFO hs.JobHistoryServer ( – STARTUP_MSG:
    STARTUP_MSG: Starting JobHistoryServer
    STARTUP_MSG: host = hdpm2.hdp.hadoop/
    STARTUP_MSG: args = []
    STARTUP_MSG: version =
    @ @ @ @ @ @ @ @ @ @ @ @ @ @ @ @
    “mapred-mapred-historyserver-hdpm2.hdp.hadoop.log” 13243L, 1500025C
    Kindly let me know what can be done ?

    Sri Sushma K

    Hi Again,

    I set the Java path and now got the result for jps as
    22142 Bootstrap
    20817 RunJar
    19336 QuorumPeerMain
    23334 SecondaryNameNode
    22648 ResourceManager
    26332 RunJar
    20016 JobHistoryServer
    32168 Jps
    21457 RunJar

    What next? Thank you

    Sri Sushma K

    Hi again,
    My History server is shown to run on 20016 and from ambari when I click on the link it open on 19888. However I could not access even when I tried with 20016. Please help. Thank You

    Kenny Zhang

    Hi Sri,

    The 20016 is the process ID, if you didn’t change the port of Job History server. I think it’s still listening on the port 19888.
    So could you please issue the following command from the secondary master node and the work station which you browse JobHistory UI from?

    # telnet hdpm2.hdp.hadoop 19888

    Please share the output of the above two commands.


    Sri Sushma K

    from the station where I access Web UI :

    Connecting To hdpm2.hdp.hadoop…Could not open connection to the host, on port
    19888: Connect failed

    from secondary master node :

    Connected to hdpm2.hdp.hadoop.
    Escape character is ‘^]’.

    What next Kenny, Thank you .

    Kenny Zhang

    Hi Sri,

    This test result means that the Job History service is up and running, listening on the port 19888 correctly.
    The reason you cannot access it from your work station is due the network issue or might be firewall blocking it. Please work with your network team to open all necessary port, you can verify this by doing the same test and make sure you got the same result as running on the secondary master node.


    Sri Sushma K

    Hi Kenny,

    Thank you for the reply! That was actually a straight forward issue, dunno how I missed it !

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.