Home Forums HDP on Windows – Installation master and regionserver started fail

This topic contains 3 replies, has 2 voices, and was last updated by  Seth Lyubich 1 year, 2 months ago.

  • Creator
    Topic
  • #32881

    Aaa Aaa
    Member

    I successfully installed HDP 1.3 on Windows
    namenode,datanode,hive,and other services already successfully started.
    but Failed_Start master regionserver
    ——————————–
    Here is the error message in master.trace.log:
    HadoopServiceTraceSource Information: 0 : Loading service xml: C:\hdp\hadoop\hbase-0.94.6.1.3.0.0-0380\bin\master.xml
    DateTime=2013-08-22T02:34:23.9268430Z
    Timestamp=604004639813
    HadoopServiceTraceSource Error: 0 : Failed to parse the service xml with exceptionSystem.Xml.XmlException:The root element is missing.
    at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
    at System.Xml.XmlDocument.Load(XmlReader reader)
    at System.Xml.XmlDocument.Load(String filename)
    at HadoopServiceHost.ServiceHost.InitInternal(String fileName)
    DateTime=2013-08-22T02:34:23.9894222Z
    Timestamp=604005210775
    ——————————————————
    master.xml file has no content, how should I do it?

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #33023

    Seth Lyubich
    Keymaster

    Hi,

    This issue appears to be similar to http://hortonworks.com/community/forums/topic/hdp-1-3-flumeagent-and-hbase-services-will-not-start/#post-33021 . I provided some things to try on that post. Please let me know if it is helpful.

    Thanks,
    Seth

    Collapse
    #32883

    Aaa Aaa
    Member

    I have already run “hadoop namenode -format”,But there are still problems

    Collapse
    #32882

    Aaa Aaa
    Member

    Here is the error message in regionserver.trace.log:
    HadoopServiceTraceSource Information: 0 : Loading service xml: C:\hdp\hadoop\hbase-0.94.6.1.3.0.0-0380\bin\regionserver.xml
    DateTime=2013-08-22T02:34:53.0916177Z
    Timestamp=604295811628
    HadoopServiceTraceSource Error: 0 : Failed to parse the service xml with exceptionSystem.Xml.XmlException: The root element is missing.
    at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
    at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
    at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
    at System.Xml.XmlDocument.Load(XmlReader reader)
    at System.Xml.XmlDocument.Load(String filename)
    at HadoopServiceHost.ServiceHost.InitInternal(String fileName)
    DateTime=2013-08-22T02:34:53.1375508Z
    Timestamp=604296272276

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)