Home Forums HDP on Linux – Installation NameNode is not starting after install on HDP2.0 on RHEL 5.8

This topic contains 5 replies, has 2 voices, and was last updated by  Sivagamasundari Veerabahu 5 months, 3 weeks ago.

  • Creator
    Topic
  • #42196

    when I try to start the name node manually,
    using su -l hdfs -c “/usr/lib/hadoop/sbin/hadoop-daemon.sh –config /etc/hadoop/conf start namenode”

    FATAL namenode.NameNode (NameNode.java:main(1325)) – Exception in namenode join
    java.io.IOException: NameNode is not formatted.

    Also I see the below warnings on the log
    2013-10-28 21:48:07,378 WARN common.Util (Util.java:stringAsURI(56)) – Path /opt/openv/hadoop/hdfs/namenode should be specified as a URI in configuration fi
    les. Please update hdfs configuration.
    2013-10-28 21:48:07,378 WARN common.Util (Util.java:stringAsURI(56)) – Path /var/log/hadoop/hdfs/namenode should be specified as a URI in configuration files. Please update hdfs configuration.
    2013-10-28 21:48:07,378 WARN common.Util (Util.java:stringAsURI(56)) – Path /opt/teamquest/hadoop/hdfs/namenode should be specified as a URI in configuration files. Please update hdfs configuration.
    2013-10-28 21:48:07,378 WARN common.Util (Util.java:stringAsURI(56)) – Path /tech/hadoop/hdfs/namenode should be specified as a URI in configuration files.Please update hdfs configuration.
    2013-10-28 21:48:07,379 WARN common.Util (Util.java:stringAsURI(56)) – Path /tech/sys/hadoop/hadoop/hdfs/namenode should be specified as a URI in configuration files. Please update hdfs configuration.
    2013-10-28 21:48:07,379 WARN common.Util (Util.java:stringAsURI(56)) – Path /opt/openv/hadoop/hdfs/namenode should be specified as a URI in configuration files. Please update hdfs configuration.
    2013-10-28 21:48:07,379 WARN common.Util (Util.java:stringAsURI(56)) – Path /var/log/hadoop/hdfs/namenode should be specified as a URI in configuration files. Please update hdfs configuration.

    Please advice

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #42261

    when I do [t15bw5h@if21t01ha ~]$ su – hdfs
    Password:
    its asking for a password

    Collapse
    #42258

    Dave
    Moderator

    Hi,

    From root you should be able to su – hdfs
    The command is:

    hadoop namenode -format

    Note there is not HDFS infront of it.

    Regards

    Dave

    Collapse
    #42235

    When trying to run the format as ,

    $ sudo su -l hdfs -c “hdfs hadoop namenode -format”
    I am getting the below error , Please advice

    Exception in thread “main” java.lang.NoClassDefFoundError: hadoop
    Caused by: java.lang.ClassNotFoundException: hadoop
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    Could not find the main class: hadoop. Program will exit.

    Collapse
    #42234

    Thanks Dave,
    Whats the default password for hdfs.. I dont recall setting one during install.

    Or can I do
    sudo su -l hdfs hadoop namenode -format ?
    Please let me know

    Collapse
    #42232

    Dave
    Moderator

    Hi,

    You need to run the following command as ‘hdfs’

    hadoop namenode -format

    Thanks

    Dave

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)