Home Forums Hortonworks Sandbox newbie. Installed VMPlayer and sandbox

This topic contains 13 replies, has 3 voices, and was last updated by  sagar 2 months, 3 weeks ago.

  • Creator
    Topic
  • #27034

    sagar
    Participant

    Hi,

    I have installed VMPlayer and sandbox successfully. But when I try to execute any sample query, I do not get the query output. Iam on Windows 7, 32-bit.
    Please suggest a solution.

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #59921

    sagar
    Participant

    I am able to start the VM and also start hadoop. Iam getting the URL on the last screen. But when I try to use the URL : http://192.168.211.129/ It is giving the below error :-

    Proxy Error
    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request GET /.
    Reason: Error reading from remote server
    ________________________________________
    Apache/2.2.15 (CentOS) Server at 192.168.211.129 Port 80

    Can you help in this as to why the URL is giving the above error.

    Our IT team had flushed the DNS and increased the network speed prior to starting the VM.

    Please suggest.

    Thanks,
    Sagar

    Collapse
    #59846

    sagar
    Participant

    Hi
    I had installed hadoop Sandbox 1.3; Now want to connect to any social media site and get some verifiable data into the sandbox.
    How do I do it ? Which section to refer to ?

    Thanks in Advance,
    Sagar

    Collapse
    #27867

    tedr
    Moderator

    Hi Sagar,

    Thanks for letting us know that Sandbox 1.3 is working for you.

    Ted.

    Collapse
    #27706

    sagar
    Participant

    Hi Ted,

    I was able to download “Hortonworks+Sandbox+1.3+VMware+RC6″ and import it.
    Also, Iam able to browse “sample_07″ table data.

    Now, I have two hadoop servers…

    Thanks for all your help.

    Regards,
    Sagar

    Collapse
    #27649

    tedr
    Moderator

    Hi Sagar,

    Thanks for letting us kn ow that the Sandbox is working for you now.

    Thanks,
    Ted.

    Collapse
    #27610

    sagar
    Participant

    Hi Cheryle,

    Thanks, got the correct sandbox but this time used a oracle virtualbox. I used default settings and can login into the URL.
    I cloned an existing query and tried to run it, but it doesn’t produce the output. It gives a screen “Waiting for query…Unsaved Query”.

    So, I tried to browse the table “sample_07″ and it did show me an output.

    My profile is “hue”.

    I think, I have got the installation going …

    Thanks again and appologies to Ted [ I should have checked the downloads first before even begining ]…

    Thanks,
    Sagar

    Collapse
    #27512

    Cheryle Custer
    Moderator

    Hi Sagar,

    The version of Sandbox you are using does not support a 32-bit OS. The latest version of the Sandbox, released this week, does support 32-bit. Please download the Sandbox 1.3 version and see if that solves your issue.

    Thanks!

    Cheryle

    Collapse
    #27503

    sagar
    Participant

    Hi tedr,

    I checked the virtualization and it has been enabled in the BIOS. I plan to attempt another installation on another windows 7 box [ 32 bit] with VT enabled.

    Just to retierate , I have VMware – VMware-player-5.0.2-1031769 and the sandbox provided as file name Sandbox+HDP+Bombardier2+(14.03)+VMware

    I will update on this post once i complete my attempt.
    Thanks

    Collapse
    #27502

    sagar
    Participant

    Hi,

    I checked into the console and its showing the current date “June 14th” 8:14 EDT …thats the current date…
    I went furthur and checked the output of ps -aef|wc -l …get 165 lines…

    I also am able to see processes running under user’s :- sandbox, hive, hbase, postgres,mapred,hdfs,oozie.apache, nobody…and ofcourse, root. That means, processes are up and running.

    Iam thinking that about my BIOS setting for enabling virtualization. I didnt do that. have asked my IT team to get in and do it.

    But, if its not my BIOS setting, could it be anything else ?

    Thanks !

    Collapse
    #27410

    tedr
    Moderator

    Hi Sagar,

    What is the date as reported by the Sandbox VM? Log into the sandox console and issue the command “date”

    Thanks,
    Ted.

    Collapse
    #27239

    sagar
    Participant

    Hi,

    I checked the option “Server Logs” and found one error repeatedly for 7th June :

    [07/Jun/2013 17:13:08 +0000] access INFO 192.168.20.1 sandbox – “GET /debug/check_config_ajax HTTP/1.0″[07/Jun/2013 17:13:08 +0000] models ERROR Permission object not available. Was syncdb run after installation?
    Traceback (most recent call last):
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 102, in has_hue_permission
    perm = self._lookup_permission(app, action)
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 97, in _lookup_permission
    return HuePermission.objects.get(app=app, action=action)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/manager.py”, line 132, in get
    return self.get_query_set().get(*args, **kwargs)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/query.py”, line 341, in get
    % self.model._meta.object_name)
    DoesNotExist: HuePermission matching query does not exist.[07/Jun/2013 17:13:08 +0000] access INFO 192.168.20.1 sandbox – “GET /hcatalog/create/create_table HTTP/1.0″[07/Jun/2013 17:13:08 +0000] models ERROR Permission object not available. Was syncdb run after installation?
    Traceback (most recent call last):
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 102, in has_hue_permission
    perm = self._lookup_permission(app, action)
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 97, in _lookup_permission
    return HuePermission.objects.get(app=app, action=action)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/manager.py”, line 132, in get
    return self.get_query_set().get(*args, **kwargs)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/query.py”, line 341, in get
    % self.model._meta.object_name)
    DoesNotExist: HuePermission matching query does not exist.[07/Jun/2013 17:13:05 +0000] access INFO 192.168.20.1 sandbox – “GET /debug/check_config_ajax HTTP/1.0″[07/Jun/2013 17:13:05 +0000] models ERROR Permission object not available. Was syncdb run after installation?
    Traceback (most recent call last):
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 102, in has_hue_permission
    perm = self._lookup_permission(app, action)
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 97, in _lookup_permission
    return HuePermission.objects.get(app=app, action=action)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/model

    …….

    Also, I tried running the sample query again but no luck.

    Interestingly, I did not see any logs for today in the “Server Logs” option.
    Why isnt the server writing anything to the log !!!!!?????

    Thanks

    Collapse
    #27162

    tedr
    Moderator

    Hi Sagar,

    From the snippet you posted earlier there is no error shown, it looks like it was successful as far as it got. It could be that since you are on a 32bit OS it may be taking longer that expected to complete as the sandbox is a 64bit vm.

    thanks,
    Ted.

    Collapse
    #27035

    sagar
    Participant

    When I try to browse data from table `sample_07`, i get the below log :

    13/06/07 10:34:10 INFO exec.HiveHistory: Hive history file=/tmp/sandbox/hive_job_log_sandbox_201306071034_503065755.txt
    13/06/07 10:34:12 INFO ql.Driver:
    13/06/07 10:34:12 INFO parse.ParseDriver: Parsing command: SELECT * FROM `sample_07`
    13/06/07 10:34:12 INFO parse.ParseDriver: Parse Completed
    13/06/07 10:34:12 INFO parse.SemanticAnalyzer: Starting Semantic Analysis
    13/06/07 10:34:12 INFO parse.SemanticAnalyzer: Completed phase 1 of Semantic Analysis
    13/06/07 10:34:12 INFO parse.SemanticAnalyzer: Get metadata for source tables
    13/06/07 10:34:12 INFO hive.log: DDL: struct sample_07 { string code, string description, i32 total_emp, i32 salary}
    13/06/07 10:34:12 INFO parse.SemanticAnalyzer: Get metadata for subqueries
    13/06/07 10:34:12 INFO parse.SemanticAnalyzer: Get metadata for destination tables
    13/06/07 10:34:13 INFO parse.SemanticAnalyzer: Completed getting MetaData in Semantic Analysis
    13/06/07 10:34:13 INFO hive.log: DDL: struct sample_07 { string code, string description, i32 total_emp, i32 salary}
    13/06/07 10:34:13 INFO ppd.OpProcFactory: Processing for FS(11)
    13/06/07 10:34:13 INFO ppd.OpProcFactory: Processing for SEL(10)
    13/06/07 10:34:13 INFO ppd.OpProcFactory: Processing for TS(9)
    13/06/07 10:34:13 INFO hive.log: DDL: struct sample_07 { string code, string description, i32 total_emp, i32 salary}
    13/06/07 10:34:13 INFO parse.SemanticAnalyzer: Completed plan generation
    13/06/07 10:34:13 INFO ql.Driver: Semantic Analysis Completed
    13/06/07 10:34:13 INFO ql.Driver: Returning Hive schema: Schema(fieldSchemas:[FieldSchema(name:code, type:string, comment:null), FieldSchema(name:description, type:string, comment:null), FieldSchema(name:total_emp, type:int, comment:null), FieldSchema(name:salary, type:int, comment:null)], properties:null)
    13/06/07 10:34:13 INFO ql.Driver:
    Hive history file=/tmp/sandbox/hive_job_log_sandbox_201306071034_5676716.txt
    13/06/07 10:34:13 INFO exec.HiveHistory: Hive history file=/tmp/sandbox/hive_job_log_sandbox_201306071034_5676716.txt
    13/06/07 10:34:14 INFO ql.Driver:
    13/06/07 10:34:14 INFO ql.Driver: Starting command: SELECT * FROM `sample_07`

    — end of log —-

    Collapse
Viewing 13 replies - 1 through 13 (of 13 total)