Home Forums HDP on Linux – Installation Nodes missed when do bootstrap

This topic contains 7 replies, has 6 voices, and was last updated by  Sasha J 2 years ago.

  • Creator
    Topic
  • #5891

    Edy Liu
    Member

    Thanks for you guys’ develop HDP.
    but i met a strange issue when build the cluster.

    Finding reachable nodes: All 3 nodes succeeded
    Obtaining information about reachable nodes: All 3 nodes succeeded
    Verifying and updating node information: All 3 nodes succeeded

    # i have 3 nodes. but why here only 1 node.
    Preparing discovered nodes: 1 / 1 in progress

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #10501

    Sasha J
    Moderator

    Avinash,
    Use script mentioned in the following post:

    http://hortonworks.com/community/forums/topic/hmc-installation-support-help-us-help-you/

    Provide us with the results.

    Collapse
    #10500

    hi can any one help e out i am getting following error while installing i am attaching error
    which i got for hmc.log file
    [2012:10:03 10:51:49][INFO][verifyAndUpdateNodesInfo][verifyAndUpdateNodesInfo.php:338][]: Going to persist discovered node properties
    [2012:10:03 10:51:50][INFO][Add nodes poller][nodesActionProgress.php:54][]: Cluster Name: PAXCEL Root Txn ID: 23
    [2012:10:03 10:51:50][ERROR][sequentialScriptExecutor][sequentialScriptRunner.php:272][]: Encountered total failure in transaction 102 while running cmd: /usr/bin/php ./addNodes/verifyAndUpdateNodesInfo.php with args: PAXCEL root 23 102 24 /var/run/hmc/clusters/PAXCEL/hosts.txt
    [root@n1 hmc]# rpm -qa|grep php

    Thanks in advance

    Collapse
    #9834

    @ Vitthal,
    I have same problem.. having 3-node cluster.. among them 2 succeeded in preparing discovered node but 1 is still processing from long time.

    Thanks,
    Saurabh

    Collapse
    #5895

    Thanks for the feedback, we will investigate further make necessary corrections.

    Collapse
    #5894

    Edy Liu
    Member

    Thanks for the reply.

    I noticed there is some warning when install hmc. my OS CentOS 5.8 x64. said php53-common conflicts with php-common. php-common is php 5.1.x. i used skip-broken. then the installation completed.

    i uninstalled php-5.1, and replaced with php 5.3. looks fine now

    btw, i think the deps of hmc maybe can have a tiny update. /usr/bin/php deps seems will install php 5.1.x by default.

    Collapse
    #5893

    Sorry for the delayed response. Is it possible for you to send us the HMC log to find the exact reason, some times it could be transient issue due to network problems. So I would suggest to retry. You should find the HMC log at /var/log/HMC/HMC.log

    Send it to gogate@hortonworks.com

    Thanks

    Collapse
    #5892

    Art Ignacio
    Member

    Hi Edy,

    Thanks for trying out HDP 1.0. Sounds like the installation is having a problem finding nodes beyond the first one. We’ll look into it and likely come back and request additional information.

    -Art

    Collapse
Viewing 7 replies - 1 through 7 (of 7 total)