The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

NotImplementedError at /accounts/login/

  • #29130

    I just re-downloaded VirtualBox-4.2.16-86992-Win.exe and Hortonworks+Sandbox+1.3+VirtualBox+RC6.ova, but the first thing that happens after I go to and click Start is a page is displayed with this error: NotImplementedError at /accounts/login/ — so I can’t work with File Browser, etc.

    It was working fine two days ago. The only thing that’s happened since then is Oracle VirtualBox-4.2.16-86992-Win.exe came out, but I’ve tried using the previous version of Virtual Box and the error still occurs.

    I just got introduced to Hortonworks and Sandbox at 2013 Hadoop Summit and took George Trujillo’s Hadoop Essentials class, and would love to practice what I learned, but this has me stopped in my tracks. Can someone help? Manish is on vacation and I don’t want to bother him, and George doesn’t seem to be getting my emails.

    Since there’s more space, here are the headers for the rest of the error text, which is voluminous:

    NotImplementedError at /accounts/login/
    Request Method: GET
    Request URL:
    Django Version: 1.2.3
    Exception Type: NotImplementedError
    Exception Value:
    Exception Location: /usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/contrib/auth/ in save, line 427
    Python Executable: /usr/bin/python2.6
    Python Version: 2.6.6
    Python Path:

  • Author
  • #29175

    Hi Robert,

    Occasionally we get some strange errors like this because the import of the appliance didn’t go well, can you try importing it again? And just to be sure when you import it you are using the ‘file->import appliance’ menu item correct?



    I did this but when I selected the appliance and clicked the green Start arrow I got an error message: Cannot access the kernel driver! Make sure the kernel module has been loaded successfully.

    I will re-download and install the Oracel VM VirtualBox Manager and then import the appliance again.

    By the way, when I install the Oracle VM VirtualBox Manager, Hortonworks Sandbox 1.3 already appears in the left-hand panel. I haven’t been going through the separate steps to install the appliance because it was already there. Should I remove it first?

    There is also an appliance called Windows XP in the left hand panel. I.e., the left hand panel isn’t blank, it has two appliances, Windows XP and Hortonworks Sandbox 1.3 already displayed when Oracle VM VirtualBox Manager finishes installing. Should I remove them and then import Hortonworks Sandbox 1.3?


    I re-downloaded and re-installed Oracle VM VirtualBox Manager twice, the first time I selected repair without success, but the second time I selected remove. This was much more lengthy, and it required the process to be repeated again to install Oracle VM VirtualBox Manager after removing it, but something different happened after I clicked on the green Start arrow: the Hortonworks Sandbox Registration page appeared. After filling it out and submitting, the Sandbox welcome page appeared, and then after I clicked Start, the Sandbox appeared including File Browser and I was in business again.

    I found that both the pre-existing and the new graphics for Hortonworks Sandbox 1.3 and 1.3_1 were displayed on the left panel, but I removed them and went through the steps to import the appliance.

    Also, I kept the 1.9gb Hortonworks Sandbox 1.3 file in a separate folder from the Oracle VM VirtualBox Manager until it was through installing.

    So the solution was to remove Oracle VM VirtualBox Manager, not just repair, and then reinstall Oracle VM VirtualBox Manager; then import the hortonworks Sandbox appliance.

    I went through the steps we followed in George’s Hadoop Essentials class demo at the 2013 Hadoop Summit successfully. Then I closed the appliance, closed the VirtualBox, closed the browser window in Chrome that had the File Browser; and then re-opened everything to make sure it opened up but this time without the Registration page, and it did; and then I went through the demo successfully.

    Needless to say, this is a huge relief – but I’ll say so anyway, this a huge relief, it lets me go forward to practice what I learned, so thanks very much!!


    Hi Robert,

    Thanks for letting us know that you got it working.



    I’m now receiving this exact same message for reasons that I don’t know or understand. The exception location is Exception Location: /usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/contrib/auth/ in save, line 427

    The “solution” is to reload everything? I’ve done a great deal of work and it’s start over because it’s a weird message that comes up every once in a while? I think this sandbox is a great thing, but have never worked the Django (not my interest), but should I take it on out of self defense?


    I am also facing the same issue. currently i am using Hortonworks_sandbox2.1

    File “/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/core/handlers/” in get_response
    100. response = callback(request, *callback_args, **callback_kwargs)
    File “/usr/lib/hue/desktop/core/src/desktop/auth/” in dt_login
    114. login(request, user)
    File “/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/contrib/auth/” in login
    File “/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/contrib/auth/” in save
    427. raise NotImplementedError

    Exception Type: NotImplementedError at /accounts/login/
    Exception Value:

    One of the django developer suggested me to upgrade from Django 1.2 to Django 1.7 and make changes in at location “/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/contrib/auth/” should be modified in such a way that it should authenticate the user first, and then login.

    I think hortonworks should upgrade from django 1.2 to django 1.7 and consider these changes.
    Please let me know if am wrong or if these changes are already implemented in the new version of sandbox.

    Gokul S

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.