Home Forums Hive / HCatalog ODBC error: Invalid sasl status

This topic contains 4 replies, has 3 voices, and was last updated by  Venkat Venugopal 11 months, 3 weeks ago.

  • Creator
    Topic
  • #33068

    Steen Paulsen
    Participant

    I’m having difficulties with the ODBC driver, both 32-bit and 64-bit.
    When I try to access my Single Node hive (Running HDP 1.3 on Windows Server 2012 in VirtualBox), I get the following error:

    Driver Version: V1.2.0.1005

    Running connectivity tests…

    Attempting connection
    Failed to establish connection
    SQLSTATE: HY000[Hortonworks][Hardy] (34) Error from Hive: invalid sasl status.

    TESTS COMPLETED WITH ERROR.

    All services seems to be starting and running fine. I am though getting errors when running SmokeTests – “copyFromLocal: `11171ยด: specified destination directory does not exist”.
    I don’t know if the above has anything to do with it.

    I’m connecting to Hive Server 2 on port 10001 with user name “hadoop”. The host computer is running Windows 8 Pro, and the VirtualBox VM is running in Bridget Ethernet mode in order to get its own IP-address.
    Any clues on what could be wrong?

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #44960

    Venkat Venugopal
    Participant

    Finally i was able to solve the connectivity issue, these are my parameters (authentication mechanism and the http path was the change.

    Port: 10000
    Database: default
    Authentication Mechanism : Windows Azure HDInsight Emulator
    HTTP Path: http://localhost:50075

    Thanks,
    Venkat

    Collapse
    #44803

    Yi Zhang
    Moderator

    Hi,

    SASL is the authentication part. Have you tried other authentication mechanism? For non-secure cluster, the password is not checked.

    Thanks,
    Yi

    Collapse
    #44272

    Venkat Venugopal
    Participant

    Sorry forgot to mention the details

    Driver Version: V1.0.0.0

    Running connectivity tests…

    Attempting connection
    Failed to establish connection
    SQLSTATE: HY000[Microsoft][Hardy] (34) Error from Hive: invalid sasl status.

    TESTS COMPLETED WITH ERROR.

    Port: 10000
    Database: default
    Authentication Mechanism : User Name and Password
    username: hadoop
    password: mk:!uR?t%=ySoB%:;!p0

    Eagerly waiting for a reply soon.

    Collapse
    #44271

    Venkat Venugopal
    Participant

    Hi Steen Paulsen,

    Any luck with identifying the solution. I am getting the same error. IF any one can help , kindly do…

    Venkat

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)