Home Forums Hortonworks Sandbox odbc not showing up in excel 2010

Tagged: 

This topic contains 10 replies, has 9 voices, and was last updated by  Daniele 4 months, 2 weeks ago.

  • Creator
    Topic
  • #36174

    Mark Malter
    Member

    I installed the ODBC driver and the test ran successfully, but when I attempt tutorial 8 and open a spreadsheet and go to Data > From other sources > From Microsoft query, there is no ‘Sample Hortonworks Hive DSN* option in the Choose Data Source dialog box.

    I’m using Excel 2010. Do I need to update to 2013? Or might there be another problem?

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #53382

    Daniele
    Participant

    Same problem using Office 2010, solved with the installation of the 32 bit ODBC driver! ;)

    Collapse
    #49520

    David Chan
    Participant

    Yah I found out the issue . You need to have MSoffice Pro 2013 or msoffice pro plus to make this work.
    search the article regarding this in Hortonworks. Its a separate article itself.
    took me a long time to find out.

    Collapse
    #49509

    Sriraman S
    Participant

    I have the same problem. Hortonworks ODBC not showing up in the data source dialog box.
    Kindly help me.

    Collapse
    #46544

    Sree Priyanka Uppu
    Participant

    Thanks Bill.
    I followed your advise and now I can see “Sample Hortonworks Hive DSN” in the ODBC sources for Excel

    Collapse
    #45519

    Bruno Kelpsas
    Participant

    I am having the same issue in Excel 2013. Driver not showing in Excel 2013. Using 64-bit driver. Did ‘Test’ in ‘ODBC Data Source Administrator’ and it was Successful. I am using latest VMWare Player. Please advise….thanks….Bruno

    Collapse
    #44877

    David Chan
    Participant

    I have almost the same issue with connection with excel.
    I used the name “Sample Hortonworks Hive DSN”
    Currently I am using vmware with hortonwork 2.0 on the linux build
    “dsn contains and architechure mismatch between the driver and application”
    I changed the dsn name to hadoop also still didnt work can you assist with advise on this.
    Thanks

    Collapse
    #38710

    Bill Matera
    Participant

    I had same problem with using Excel 2010. You need to install the 32-bit driver since Excel 2010 is 32-bit app. Worked fine once I installed it.

    Collapse
    #37857

    Deepak Pawar
    Member

    Hi,
    I have the same issue (however, I am using excel 2007). the connection name does appear in the list when I try to choose the datasource name from excel.
    When I test the connection from ODBC, it was completed successfully.

    Thanks for your help.

    Collapse
    #36210

    Mark Malter
    Member

    Hi Ron,
    Still having problems. On my Hortonworks Hive ODBC Driver Setup screen I have:
    Data Source Name: Sample Hortonworks Hive DSN
    Description: Sample Hortonworks Hive DSN
    Database: default
    Hive Server 2 and Mechanism User name
    User Name : Hadoop

    In excel, when I go to Data > From other sources > From Microsoft query, in the Choose Data Source dialog box I see only:

    dBASE Files*
    Excel Files*
    MS Access Database*

    But unlike in your Tutorial 8, I don’t have the “Sample Hortonworks Hive DSN*” option in the ‘Choose Data Source’ dialog box.

    Thank you for your help.

    Collapse
    #36176

    Ron Lee
    Member

    Mark,
    Hi! When you created the connection in the ODBC administrator you gave the connection a name. It is at the very top of the dialog box. If you look at the tutorials on setting up ODBC I usually call it Hadoop. The connection name will be what shows up in the list of data sources. If you are still having problems let us know and I can dig up the screenshots for you.

    Ron

    Collapse
Viewing 10 replies - 1 through 10 (of 10 total)