Oozie Forum

Oozie Coordinator Issue

  • #10447

    I am new to Oozie but I am pretty sure I have the frequency set to once an hour or every 60 minutes in the coordinator config but it keeps running at 5 minute intervals.

    Here is my coordinator.xml – http://jonathanhodges.com/coordinator.xml

    Here is my recommendations-coordinator.properties


    I then start the job with the following command.

    oozie job -config /home/hadoop/oozie/recommendations/recommendations-coordinator.properties -run

    I have tried setting frequency to both 60 and ${coord:hours(1)} but I still see the same 5 minute execution intervals.

    Here is a screenshot of the Oozie web console – http://jonathanhodges.com/oozie_web_console.png

    As you can see the coordinator job says frequency 60 and unit MINUTE but you can see the workflow jobs are running every five minutes.

    Any ideas?

    Thanks in advance,


to create new topics or reply. | New User Registration

  • Author
  • #10448

    This looks to be related – if you look at the web console screenshot you can see a column called ‘Nominal Time’. While the ‘Created Time’ increments by 5 minutes ‘Nominal Time’ increments by an hour which is the interval I want. Does anyone know what Nominal Time is and how it is calculated?

    Carter Shanklin

    Config looks OK to me, oozie has had some strange issues in the past related to timezone (see for example OOZIE-207). Is your cluster in UTC? Can you try setting it to be if not?


    Hi Carter,

    As you can see in the coordinator.xml we are using UTC time. We figured out the issue as we had a start date of 9/28, and the current date was 9/29. In this scenario, Oozie will submit workflows for all the intervals that were missed starting from the start time.. That’s just how Oozie works. The nominal time is the actual time interval (hour) that the workflow is supposed to process.

    You can control how many workflows are concurrently running and pending for the coordinator by specifying and elements in coordination.xml respectively, as in below:


    Shay Katz


    I’m encountering the same issue too.
    Have you found any solution?



    The answer is right above you 😉

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.