Home Forums Oozie Oozie Deadlock

This topic contains 0 replies, has 1 voice, and was last updated by  Chiew Yea Kuek 10 months, 3 weeks ago.

  • Creator
    Topic
  • #45391

    Chiew Yea Kuek
    Participant

    Hi All,

    I’m trying to schedule an oozie job to run 2 sqoop action concurrently using fork in sandbox. Previously when I run in Hadoop 1 sandbox, I faced the oozie deadlock issue (where by 2 sqoop jobs hang there and it keep display “Heart beat” and the job will never end) but I am able to fixed it by apply the below settings.

    mapred.tasktracker.map.tasks.maximum = 4
    mapred.tasktracker.reduce.tasks.maximum = 4

    Now, when I tried the same oozie job in Hadoop 2 (YARN) sandbox, i faced the same deadlock issue again. However, after I tried to apply the below setting, the problem still exists.

    mapreduce.map.cpu.vcores = 4
    mapreduce.reduce.cpu.vcores = 4

    Anyone could shed me some light? Appreciate your help. Thanks.

    Regards,
    CYea

You must be logged in to reply to this topic.