The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Oozie failing to install – can I retry when other services are running?

  • #42777

    I installed HDP2 thru Ambari, everything is working fine,
    The only problem I have now is ,the ooze in dashboard is telling that it’s failed to install, but the install wizard says it installed fine.
    Not sure which is right, so obviously I don’t have an option to start Oozie,it gives me an option to reinstall
    1. Can I try to reinstall the Oozie from the dashboard when other services are up and running? Because everything else is working fine.
    2. Why did the install wizard say that the Oozie is installed ? Is there a way to check this.?
    I will start a separate thread for this one.

  • Author
  • #42779


    You can check to see on your oozie server if you have oozie installed /etc/oozie/conf
    Although if Ambari doesn’t think it is installed, then it wont be in Ambari’s database. This means it wont be able to control Oozie.
    I would try and re-install it and see if that works.




    Yes. I do see all the files under etc/Oozie/conf which means that it installed fine like the wizard said.
    But not sure why the Ambari is complaining that it is not.
    Can I try to reinstall as you suggested while the other services are running ? Or do I need to stop them.?
    Also what happens if it tries to reinstall when it’s already installed?



    Without the install logs it will make it difficult to understand what happened when it deployed it.
    I would say check if oozie is running – ps -ef | grep oozie
    Then you could remove the oozie directories and user, and then try and re-install it.




    Thanks for the advice, I removed the pid from var/run and tried the -re-install option from Ambari and it worked !!!
    All services are up and running now including Oozie.

    One final question, I wanted the GUI interface that the sandbox offered, I was assuming Hue will be installed as a part of HDP2.0 stack, But doesnt look like.
    Is this true ? Do I manually need to install Hue? is not included on HDP2.0 install thru ambari ?
    I will open a separate thread for this.

The topic ‘Oozie failing to install – can I retry when other services are running?’ is closed to new replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.