Home Forums Oozie Oozie noob question for pig jobs

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by  tedr 1 year, 6 months ago.

  • Creator
    Topic
  • #19309

    Evan Cutler
    Member

    Greetings,
    I am doing the trainings, and have successfully executed some pig jobs.
    I did the code, and clicked “Save” which put the jobs in the left column.

    Now I want those jobs in Oozie.
    I kinda understand what Oozie does, but I don’t know how to add those saved jobs into the workflow.

    What do I put in the “Script Name” field to refer to my saved PIG jobs?
    where are they saved?

    when I action the jobs (to what I think I’m doing), I get: E0701: XML schema error, cvc-elt.1.a: Cannot find the declaration of element ‘workflow-app’.

    ok, I’d like to RTFM, but I need to know where I can find it for this step in the training.
    Any help would be greatly appreciated.

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #19432

    tedr
    Member

    Hi Evan,

    I’m trying to track down where these scripts are stored, will get back to you once I find out. Also looking into if this is even possible to do.

    Thanks,
    Ted.

    Collapse
    #19419

    Evan Cutler
    Member

    Yes.
    I’m doing it in the sandbox. I have HUE running from the sandbox, and developing PIG jobs there. I hit save on the PIG developer screen, and they show up as saved jobs on the left.

    How do I take those jobs and send them to oozie? Does that even work?

    Or do I have to export all of them out to pig files set class-paths and all that jazz and then put it into oozie?

    Thanks.

    Collapse
    #19418

    tedr
    Member

    Hi Evan,

    Are you “doing the trainings” in the Hortonworks Sandbox?

    Thanks,
    Ted

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)