Home Forums HDP on Windows – Non Installation issues Permission Error on HDFS User folder

This topic contains 2 replies, has 3 voices, and was last updated by  SambaSivaRao Y 6 months ago.

  • Creator
    Topic
  • #48069

    Carolus Holman
    Participant

    I am using the NameNode Web page to browse the file system. Clicking the Browse the filesytem link brings up a page with table listing the current directory in the HDFS system. I cannot browse the user directory. I get a Permission Denied error specifically:
    Permission denied: user=gopher, access=READ_EXECUTE, inode="/user":hadoop:hdfs:drwx------

    I have tried to CHMOD the user directory, however I get a permission denied when trying to alter the permissions.

    Is there something I missed in the configuration? The Server is running, so this is a post-installation issue. Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #52100

    SambaSivaRao Y
    Participant

    Hi Carolus,

    Can you change the below property in hdfs-site.xml and try ( Restart the services after changes).

    <property>
    <name>dfs.permissions.enabled</name>
    <value>false</value>
    <description>
    If “true”, enable permission checking in HDFS.
    If “false”, permission checking is turned off,
    but all other behavior is unchanged.
    Switching from one parameter value to the other does not change the mode,
    owner or group of files or directories.
    </description>
    </property>

    Thanks
    SambaSiva

    Collapse
    #48254

    Dave
    Moderator

    Hi Carolus,

    You need to be the hdfs user to chmod the /user permissions.
    It should have 755 permissions. If you start the command line as hdfs, then you should be able to run:
    hadoop fs -chmod -R 755 /user

    Let me know if that helps,

    Thanks

    Dave

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)