Home Forums Hue Potential misconfiguration detected. Fix and restart Hue.

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Cameron Hunt 1 week, 1 day ago.

  • Creator
    Topic
  • #57348

    Carolus Holman
    Participant

    I have been trying to get HUE running on an EC2 cluster. The Filebrowser give me this error:
    WebHdfsException at /filebrowser/
    <urlopen error [Errno 111] Connection refused>

    I have updated the ini file with my local server dns name but the error still occurs. When going to the potential mis-configuration page i see this:

    hadoop.hdfs_clusters.default.webhdfs_url Current value: http://iocalserverurl.internal:50070/webhdfs/v1/
    Failed to access filesystem root
    hcatalog.templeton_url Current value: http://localhost:50111/templeton/v1/
    Oozie Editor/Dashboard The app won’t work without a running Oozie server

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #64610

    Cameron Hunt
    Participant

    Carolus, do you have HA enabled? If so, read below.

    TL;DR
    Hue needs httpfs for a cluster with HA enabled.

    Detail
    I had the same problem because although I had enabled High Availability, I had not installed and configured httpfs (a webhdfs proxy). When my active/standby name nodes switched their status, Hue still was pointing at the original active node.

    The Fix:
    (note – I’m running HDP 2.2 on Centos 6.6, and the post-install RPM scripts for hadoop-httpfs RPM don’t properly work. If you have the same behavior, you’ll need to install the init.d script and the conf files manually)

    To configure Hue to work with Namenode HA, we need to use httpfs instead of webhdfs to communicate with the namenode.
    Below is the list of steps after the whole cluster is setup correctly with Namenode HA enabled.

    1. Install httpfs server in any node within the cluster by running: yum install hadoop-httpfs

    2. Configure httpfs-site.xml and ensure the following properties are correct:

    <property>
    <name>httpfs.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>httpfs.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    3. Add the following properties to core-site.xml for httpfs via Ambari Web UI, which requires a restart of HDFS service:
    hadoop.proxyuser.httpfs.groups=*
    hadoop.proxyuser.httpfs.hosts=*

    4. Start hadoop-httpfs service by running: service hadoop-httpfs restart

    5. Configure hue.ini by modify the below variable to:
    webhdfs_url=http://<fqdn of httpfs server>:14000/webhdfs/v1/

    6 Restart Hue.

    Collapse
Viewing 1 replies (of 1 total)