The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

MapReduce Forum

Problem to start Start MapReduce JobHistory Server

  • #26655
    yamei gu


    I followed the instruction on to start the jobhistory server. However, the first trial failed because the HADOOP_MAPRED_HOME and HADOOP_MAPRED_LOG_DIR was not defined. After manually defined these env variables, I tried to execute:

    /usr/lib/hadoop-mapreduce/sbin/ start historyserver –config $HADOOP_CONF_DIR

    And have the following error:
    nice: /Hadoop/MAPRED/bin/mapred: Permission denied

    I looked into the file, and checked $MAPRED_USER has full permission on every directory used in the “nohup nice … ” command line. Even run the “nice -n 0 /Hadoop/MAPRED/bin/mapred /etc/hadoop/conf –config historyserver” by using “root”, it still has the permission denied error.

    Any suggestion?


  • Author
  • #26798

    Hi Yamei,

    When you tried to start the jobhistory daemon with the command you show, what user were you using? were you root or your own user? or were you mapred?


    yamei gu

    Ted, I was using su $mapred_user, as noted in the instruction.


    Hi Yamei,

    Have you tried it without the nice command?


    yamei gu

    What do you mean without nice command? Can you elaborate more?


    Hi Yamei,

    What I mean is do not preceed the command with ‘nice,’ just run the command
    su hdfs -c ‘/usr/lib/hadoop/bin/ start historyserver’


    ulka asati

    I am facing permission issue while starting the jobhistory server on RHEl 6.2 linux machine.
    I am following this doc.

    Error I am facing is

    [mapred@4f00244d8025 bin]$ /usr/lib/hadoop-mapreduce/sbin/ start historyserver –config $HADOOP_CONF_DIR

    mkdir: cannot create directory `’: No such file or directory
    chown: missing operand after `mapred’
    Try `chown –help’ for more information.
    starting historyserver, logging to /mapred-mapred-historyserver-4f00244d8025.out
    /usr/lib/hadoop-mapreduce/sbin/ line 116: /mapred-mapred-historyserver-4f00244d8025.out: Permission denied

    Pl let me know what more configuration is required

The forum ‘MapReduce’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.