HDP on Linux – Installation Forum

problems with ambari wizard

  • #17688

    Hi everybody.
    I’m trying to install HDP 1.2 on amazon (small instance).

    I followed the documentation, and i have installed ambari server.

    When i try to start ambari everything seems ok.
    this is the message log:

    Using python /usr/bin/python2.6
    Starting ambari-server
    Checking iptables…
    iptables is disabled now
    Running server: /usr/jdk64/jdk1.6.0_31/bin/java -server -XX:NewRatio=2 -XX:+UseConcMarkSweepGC -Xms512m -Xmx2048m -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/lib/ambari-server/*:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/usr/lib/ambari-server/* org.apache.ambari.server.controller.AmbariServer >/var/log/ambari-server/ambari-server.out 2>&1

    if i check the ambari-server.out i find only this two lines:

    [EL Info]: 2013-03-16 15:03:31.552–ServerSession(41912610)–EclipseLink, version: Eclipse Persistence Services – 2.4.0.v20120608-r11652
    [EL Info]: connection: 2013-03-16 15:03:33.172–ServerSession(41912610)–file:/usr/lib/ambari-server/ambari-server- login successful

    if i run this command: ps -ef | grep Ambari
    i can’t find any process running

    Obviously if i try to reach ambari wizard from http://:8080 nothing happens.

    Can you help me please?
    Thank you in advance.


to create new topics or reply. | New User Registration

  • Author
  • #17689

    Some additional information.

    I’m running Centos 6.2

    i don’t see any service listening on port 8080

    i started httpd on port 80 just to test the connectivity and everything goes fine with it.

    Larry Liu

    Hi, Rubens,

    Thanks for trying HDP.

    Can you please also check ambari-server.log?

    You can also run following command to check if there is ambari java process running:

    Another command to check if the port 8080:

    netstat -an| grep 8080

    Please let us know.



    Thank you Larry.

    I solved the problem.
    It was a stupid hostname issue that caused several ambari-server errors.

    Now i’m working on HBase, Hive, Zookeper issues.
    When i try to start those services something goes wrong.


    Hi Rubens,

    What is it that goes wrong when you try to start these services? Do their respective logs tell you anything?


    Rupert Bailey

    I was in a similar situation today. The clues that I got were:
    Ambari administrator could not register
    ambari-agent was running on slaves
    ambari-agent.log said it couldn’t communicate back:
    INFO 2013-07-31 11:45:21,267 NetUtil.py:41 – Connecting to the following url https://master1:8440/cert/ca
    INFO 2013-07-31 11:45:21,295 NetUtil.py:55 – Failed to connect to https://master1:8440/cert/ca due to [Errno –
    it wasn’t using the fqdn even though I changed it in /etc/sysconfig/network and restarted the OS.
    discovered that the ambari-agent.ini does not refresh and didn’t have the correct fqdn
    so changed it as shown below
    [root@client1 ~]# sed -i -e ‘s/master1/master1.localdomain/’ /etc/ambari-agent/conf/ambari-agent.ini
    ambari-agent restart
    registering then worked

    Seth Lyubich

    Hi Rupert,

    Thanks for letting us know. You can also make sure that hostname -f returns correct FQDN name as other services might need to utilize FQDN names as well.


The topic ‘problems with ambari wizard’ is closed to new replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.