Home Forums HDP on Linux – Installation register wrong

This topic contains 3 replies, has 2 voices, and was last updated by  Sasha J 1 year, 3 months ago.

  • Creator
    Topic
  • #30979

    zhiqi zhang
    Member

    I set up ambari server successfully. (ambari-server 1.2.4.9-1)
    then I open the master.cn:8080 to create a cluster
    but there is wrong when i register the hosts.

    the content in ambari-agent.log:
    INFO 2013-08-07 15:09:26,142 Controller.py:92 – Unable to connect to: https://master.cn:8441/agent/v1/register/slave1
    Traceback (most recent call last):
    File “/usr/lib/python2.6/site-packages/ambari_agent/Controller.py”, line 77, in registerWithServer
    response = self.sendRequest(self.registerUrl, data)
    File “/usr/lib/python2.6/site-packages/ambari_agent/Controller.py”, line 231, in sendRequest
    self.cachedconnect = security.CachedHTTPSConnection(self.config)
    File “/usr/lib/python2.6/site-packages/ambari_agent/security.py”, line 74, in __init__
    self.connect()
    File “/usr/lib/python2.6/site-packages/ambari_agent/security.py”, line 79, in connect
    self.httpsconn.connect()
    File “/usr/lib/python2.6/site-packages/ambari_agent/security.py”, line 63, in connect
    ca_certs=server_crt)
    File “/usr/lib64/python2.6/ssl.py”, line 350, in wrap_socket
    suppress_ragged_eofs=suppress_ragged_eofs)
    File “/usr/lib64/python2.6/ssl.py”, line 118, in __init__
    self.do_handshake()
    File “/usr/lib64/python2.6/ssl.py”, line 293, in do_handshake
    self._sslobj.do_handshake()
    SSLError: [Errno 1] _ssl.c:480: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    i noticed that there are several guys have the same problem, but the solution were almost reinstall the ambari server. who knows how many time i have reinstall my ambari server, it does not work….
    futhermore, I synchrnised the time with ntpdate in every hosts.

    looking forward to a answer, thanks a lot.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #31258

    Sasha J
    Moderator

    Good to know.
    6.4 should also work.

    Thank you!
    Sasha

    Collapse
    #31217

    zhiqi zhang
    Member

    i have solve my problem.

    i reinstall the operating system. the previous one is centos6.4. then i install a contos6.2. it work…..

    Collapse
    #31180

    Sasha J
    Moderator

    There is something wrong with agent’s certificate…
    Steps to fix:

    1. “ambari-agent stop” on ALL nodes
    2. “ambari-server” stop
    3. “yum erase ambari*” on all nodes
    4. “yum erase postgres*” on ambari node
    5. “rm -rf /var/lib/pgsql” on ambari node
    6. “yum install ambari-server”
    7. “ambari-server setup”
    8. ambari-server start
    9. http://:8080

    AT this point all nodes should be clear from the all incorrect certificates.

    Hope this help

    Thank you!
    Sasha

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)