Home Forums HDP on Linux – Installation "reposync -r HDP-1.0.1.14" does not work

This topic contains 7 replies, has 2 voices, and was last updated by  Ping Zhu 2 years, 4 months ago.

  • Creator
    Topic
  • #7911

    Ping Zhu
    Member

    Here are the error messages:

    HDP-1.0.1.14/primary | 19 kB 00:00
    Traceback (most recent call last):
    File “/usr/bin/reposync”, line 291, in ?
    main()
    File “/usr/bin/reposync”, line 179, in main
    my.doSackSetup(rpmUtils.arch.getArchList(opts.arch))
    File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 465, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
    File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 502, in _getSacks
    self.repos.populateSack(which=repos)
    File “/usr/lib/python2.4/site-packages/yum/repos.py”, line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 187, in populate
    xml = repo_get_function()
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1550, in getPrimaryXML
    return self.retrieveMD(‘primary’)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1491, in retrieveMD
    return self._retrieveMD(mdtype)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1531, in _retrieveMD
    cache=self.http_caching == ‘all’)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 816, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
    yum.Errors.NoMoreMirrorsRepoError: failure: repodata/primary.xml.gz from HDP-1.0.1.14: [Errno 256] No more mirrors to try.

    It seems to me Hortonworks updated “configuring local mirror” documentation in recent days.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #7933

    Ping Zhu
    Member

    the problem is solved now.

    Collapse
    #7928

    Ping Zhu
    Member

    yes, I created a repository for HDP 1.0.0.12 previously.

    Collapse
    #7927

    Sasha J
    Moderator

    are you doing this on a clean OS or a machine that has previous installations?

    Collapse
    #7926

    Ping Zhu
    Member

    reposync -r HDP-UTILS-1.0.1.14 works for me

    Collapse
    #7918

    Ping Zhu
    Member

    I tried repository file for both centos5 and centos6. Neither of them works

    Collapse
    #7916

    Ping Zhu
    Member

    yes, I download it and save it as /etc/yum.repos.d/hdp.repo. Here is its content:

    [HDP-1.0.1.14]
    name=Hortonworks Data Platform Version – HDP-1.0.1.14
    baseurl=http://public-repo-1.hortonworks.com/HDP-1.0.1.14/repos/centos5
    gpgcheck=0
    enabled=1
    priority=1

    [HDP-UTILS-1.0.1.14]
    name=Hortonworks Data Platform Utils Version – HDP-UTILS-1.0.1.14
    baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.0.1.14/repos/centos5
    gpgcheck=0
    enabled=1
    priority=1

    Collapse
    #7915
    Collapse
Viewing 7 replies - 1 through 7 (of 7 total)