The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

"reposync -r HDP-1.0.1.14" does not work

  • #7911
    Ping Zhu
    Member

    Here are the error messages:

    HDP-1.0.1.14/primary | 19 kB 00:00
    Traceback (most recent call last):
    File “/usr/bin/reposync”, line 291, in ?
    main()
    File “/usr/bin/reposync”, line 179, in main
    my.doSackSetup(rpmUtils.arch.getArchList(opts.arch))
    File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 465, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
    File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 502, in _getSacks
    self.repos.populateSack(which=repos)
    File “/usr/lib/python2.4/site-packages/yum/repos.py”, line 260, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 187, in populate
    xml = repo_get_function()
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1550, in getPrimaryXML
    return self.retrieveMD(‘primary’)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1491, in retrieveMD
    return self._retrieveMD(mdtype)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 1531, in _retrieveMD
    cache=self.http_caching == ‘all’)
    File “/usr/lib/python2.4/site-packages/yum/yumRepo.py”, line 816, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
    yum.Errors.NoMoreMirrorsRepoError: failure: repodata/primary.xml.gz from HDP-1.0.1.14: [Errno 256] No more mirrors to try.

    It seems to me Hortonworks updated “configuring local mirror” documentation in recent days.

  • Author
    Replies
  • #7915
    #7916
    Ping Zhu
    Member

    yes, I download it and save it as /etc/yum.repos.d/hdp.repo. Here is its content:

    [HDP-1.0.1.14]
    name=Hortonworks Data Platform Version – HDP-1.0.1.14
    baseurl=http://public-repo-1.hortonworks.com/HDP-1.0.1.14/repos/centos5
    gpgcheck=0
    enabled=1
    priority=1

    [HDP-UTILS-1.0.1.14]
    name=Hortonworks Data Platform Utils Version – HDP-UTILS-1.0.1.14
    baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.0.1.14/repos/centos5
    gpgcheck=0
    enabled=1
    priority=1

    #7918
    Ping Zhu
    Member

    I tried repository file for both centos5 and centos6. Neither of them works

    #7926
    Ping Zhu
    Member

    reposync -r HDP-UTILS-1.0.1.14 works for me

    #7927
    Sasha J
    Moderator

    are you doing this on a clean OS or a machine that has previous installations?

    #7928
    Ping Zhu
    Member

    yes, I created a repository for HDP 1.0.0.12 previously.

    #7933
    Ping Zhu
    Member

    the problem is solved now.

The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.