Home Forums HDP on Windows – Installation Run -SmokeTests Error in single node after successful installation

This topic contains 4 replies, has 2 voices, and was last updated by  Seth Lyubich 9 months, 3 weeks ago.

  • Creator
    Topic
  • #39084

    Hi,
    The installation successfully install with 16 services running. But when I run “Run -SmokeTests” command, I’m getting the following error in the command prompt window:

    C:\hdp\hadoop>Run-SmokeTests
    Hadoop smoke test – wordcount using hadoop.cmd file
    The system cannot find the path specified.
    Run-HadoopSmokeTest : Error copying the input file for the Hadoop smoke test
    At line:1 char:1
    + Run-HadoopSmokeTest
    + ~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-HadoopSmokeTest

    The system cannot find the path specified.
    Run-HadoopSmokeTest : Hadoop Smoke Test: FAILED
    At line:1 char:1
    + Run-HadoopSmokeTest
    + ~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-HadoopSmokeTest

    Pig smoke test – wordcount using hadoop.cmd file
    The system cannot find the path specified.
    The system cannot find the path specified.
    Run-PigSmokeTest : Pig Smoke Test: FAILED
    At line:1 char:1
    + Run-PigSmokeTest
    + ~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-PigSmokeTest

    Hcatalog smoke test – show tables, create table, and drop table
    Running hcat command: show tables
    python: can’t open file ‘\bin\hcat.py’: [Errno 2] No such file or directory
    Run-HCatalogSmokeTest : HCatalog Smoke Test: FAILED
    At line:1 char:1
    + Run-HCatalogSmokeTest
    + ~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-HCatalogSmokeTest

    2
    Hive smoke test – drop table, create table and describe table
    Running hive command: drop table if exists hivesmoke
    The system cannot find the path specified.
    Run-HiveSmokeTest : Hive Smoke Test: FAILED
    At line:1 char:1
    + Run-HiveSmokeTest
    + ~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-HiveSmokeTest

    3
    HiveServer2 smoke test – drop table, create table and describe table
    The system cannot find the path specified.
    Run-HiveServer2SmokeTest : HiveServer2 Smoke Test: FAILED
    At line:1 char:1
    + Run-HiveServer2SmokeTest
    + ~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorExcep
    tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
    n,Run-HiveServer2SmokeTest
    3
    Sqoop smoke test – version
    The system cannot find the path specified.
    Run-SqoopSmokeTest : Sqoop Smoke Test: FAILED

    Kindly waiting for your response.

    Thanks,
    wejden

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #39692

    Seth Lyubich
    Keymaster

    Hi Ouejdene,

    If you ran the installer with DESTROY_DATA=NO link below might be useful.

    http://hortonworks.com/community/forums/topic/namenode-cannot-be-started-after-successful-hdp-1-3-installation/

    If this link above does not help, can you please share you clusterproperties.txt file and full error on NameNode?

    Hope this helps,
    Seth

    Collapse
    #39327

    Hi Seth,

    Thanks for your reply, I can give more details because the same error in two machines. In the first I try hdp-1.3.0.0.winpkg and in the seconde one I use hdp-1.1.0-GA.winpkg and in both machines I have the same problem.

    In hadoop\logs\hadoop I got this:

    - In hadoop-datanode-WIN-EVJ328UU9Q6
    2013-10-03 000802,253 INFO org.apache.hadoop.hdfs.server.datanode.DataNode Finished asynchronous block report scan in 0ms
    2013-10-03 000802,260 INFO org.apache.hadoop.hdfs.server.datanode.DataNode BlockReport of 10 blocks took 0 msec to generate and 3 msecs for RPC and NN processing

    - In hadoop-namenode-WIN-EVJ328UU9Q6
    2013-10-03 110803,472 INFO org.apache.hadoop.hdfs.StateChange BLOCK processReport from 132.203.120.3150010, blocks 10, processing time 0 msecs

    - In hadoop-tasktracker-WIN-EVJ328UU9Q6
    2013-10-02 000003,147 INFO org.apache.hadoop.mapred.TaskTracker Failed to get system directory…

    Thanks,
    wejden.

    Collapse
    #39224

    Hi Seth,

    The environmental variable JAVA_HOME is already setup: setx JAVA_HOME “C:\java\jdk1.6.0_31″ /m
    and I also added to the path in environmental for Python: setx PATH “$env:path;C:\Python27″ /m

    Any help is much appreciated.

    Thanks,
    wejden.

    Collapse
    #39182

    Seth Lyubich
    Keymaster

    Hi Wejden,

    Can you please make sure that your environmental variable JAVA_HOME is setup and Python is added to the path in environmental variables?

    Hope this helps.

    Thanks,
    Seth

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)