Hortonworks Sandbox Forum

Sandbox 2.1 ODBC Not Working

  • #52946
    Blair Krotenko

    I have created an ODBC connection to the Sandbox 2.1 but I am not able to pull any data. The error I get is “ODBC–call failed. [Hortonworks][HiveODBC] [35] Error from Hive: error code: ‘40000’ error message: ‘Error while compiling statement: FAILED: HiveAccessControlException Permission denied. Principal [name=hue, type=USER] does not have following privileges on Object [type=TABLE_OR_VIEW, name=<table name>]: [SELECT]’, [#35]”

    This works when I use the same setup to connect to the Sandbox 2.0, I have used it many times for moving data, mostly to MS Access.

    I have tried different user names in the ODBC connection such as root, hdfs, and hadoop. I have tried various permissions on the table itself using table>view>view file location>change permissions. These did not solve it.

    Any help would be appreciated.


to create new topics or reply. | New User Registration

  • Author
  • #53368
    Jojo Thomas

    Have you got this resolved? I am getting the same error.

    Marc Sardello

    I’m experiencing the exact same problem. Any suggestions? Were you able to resolve this?


    Blair Krotenko

    This is still not resolved. Any help would be appreciated.


    Hi Blair,

    Did you try with a different username (root / hadoop?) And did you check the hive logs to see if you were hitting the server?



    Marc Sardello

    I was able to resolve this issue this morning by going in and grating permissions to hue for the specific table. Using Hive… input:

    grant SELECT on table <table name> to user hue

    Not sure why this is necessary, but it appears to work.


    Rajesh Toleti

    The following worked for me on sandbox 2.1
    grant SELECT on table webloganalytics to user hue

    Paul Hargis

    Resolved for me by adding new GRANT permission (as others said in this post):

    1) Logged into Sandbox VM (ssh root@ -p 2222)
    2) Launched hive (hive)
    3) Add new GRANT permission to hue (grant SELECT on table tweetsbi to user hue 😉
    4) Re-tried access to tweetsbi table from Excel — WORKS!

    Blair Krotenko

    Thanks for the responses, it looks like the issue is resolved.

    Pushker Sahai

    I am also having this issue. Whenever I try to view the data on excel 2011 on mac I see message “no records returned”. I have already given grant to “hue”. Thanks.

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.