Setting up ambari Server issue with Postgresql

to create new topics or reply. | New User Registration

Tagged: ,

This topic contains 4 replies, has 3 voices, and was last updated by  Jan Peters 1 month ago.

  • Creator
    Topic
  • #52612

    Markus F
    Participant

    Hi everyone,

    I tried to setup the ambari server but getting a error message like this:

    [ec2-user@ip-10-0-0-112 etc]$ sudo ambari-server setup
    Using python /usr/bin/python2.6
    Setup ambari-server
    Checking SELinux…
    SELinux status is ‘enabled’
    SELinux mode is ‘permissive’
    WARNING: SELinux is set to ‘permissive’ mode and temporarily disabled.
    OK to continue [y/n] (y)?
    Ambari-server daemon is configured to run under user ‘root’. Change this setting [y/n] (n)?
    Adjusting ambari-server permissions and ownership…
    Checking iptables…
    Checking JDK…
    Do you want to change Oracle JDK [y/n] (n)?
    Completing setup…
    Configuring database…
    Enter advanced database configuration [y/n] (n)?
    Default properties detected. Using built-in database.
    Checking PostgreSQL…
    Running initdb: This may take upto a minute.
    About to start PostgreSQL
    ERROR: Exiting with exit code 1.
    REASON: Unable to start PostgreSQL server. Exiting
    [ec2-user@ip-10-0-0-112 etc]$

    tried to stop and sto/restart/start the postgresql …but no luck

    when i tried …the following came up:

    [ec2-user@ip-10-0-0-112 etc]$ sudo /etc/init.d/postgresql restart
    Stopping postgresql service: [ OK ]
    Starting postgresql service: [FAILED]

    this is what is installed:

    postgresql-8.4.20-1.el6_5.x86_64
    postgresql-libs-8.4.20-1.el6_5.x86_64
    postgresql-server-8.4.20-1.el6_5.x86_64

    …anyone could please help ?

Viewing 4 replies - 1 through 4 (of 4 total)

You must be to reply to this topic. | Create Account

  • Author
    Replies
  • #72257

    Jan Peters
    Participant

    Okay, so I’ve run into this issue too, but I already have “127.0.0.1 localhost localhost.localdomain” in my /etc/hosts file. That said, here’s my /var/lib/pgsql/pgstartup.log
    The files belonging to this database system will be owned by user “postgres”.
    This user must also own the server process.

    The database cluster will be initialized with locale en_US.UTF-8.
    The default database encoding has accordingly been set to UTF8.
    The default text search configuration will be set to “english”.

    fixing permissions on existing directory /var/lib/pgsql/data … ok
    creating subdirectories … ok
    selecting default max_connections … 100
    selecting default shared_buffers … 32MB
    creating configuration files … ok
    creating template1 database in /var/lib/pgsql/data/base/1 … ok
    initializing pg_authid … ok
    initializing dependencies … ok
    creating system views … ok
    loading system objects’ descriptions … ok
    creating conversions … ok
    creating dictionaries … ok
    setting privileges on built-in objects … ok
    creating information schema … ok
    vacuuming database template1 … ok
    copying template1 to template0 … ok
    copying template1 to postgres … ok

    Success. You can now start the database server using:

    /usr/bin/postgres -D /var/lib/pgsql/data
    or
    /usr/bin/pg_ctl -D /var/lib/pgsql/data -l logfile start

    could not write to log file: No space left on device
    FATAL: could not write lock file “postmaster.pid”: No space left on device
    postmaster cannot access the server configuration file “/var/lib/pgsql/data/postgresql.conf”: No such file or directory
    postmaster cannot access the server configuration file “/var/lib/pgsql/data/postgresql.conf”: No such file or directory
    runuser: cannot set groups: Operation not permitted
    postmaster cannot access the server configuration file “/var/lib/pgsql/data/postgresql.conf”: No such file or directory
    postmaster cannot access the server configuration file “/var/lib/pgsql/data/postgresql.conf”: No such file or directory
    postmaster cannot access the server configuration file “/var/lib/pgsql/data/postgresql.conf”: No such file or directory

    so I need a hint on what to do next. Thanks in advance for your help.
    mit Freundlichen Grüßen (with Friendly Greetings),
    Jan

    Collapse
    #52653

    Markus F
    Participant

    Issue resolved. :) Needed to add “127.0.0.1 localhost localhost.localdomain” to the /etc/hosts file

    Collapse
    #52652

    Markus F
    Participant

    1) cat /var/lib/pgsql/pgstartup.log:

    [ec2-user@ip-10-0-0-112 ~]$ sudo cat /var/lib/pgsql/pgstartup.log
    The files belonging to this database system will be owned by user “postgres”.
    This user must also own the server process.

    The database cluster will be initialized with locale en_US.UTF-8.
    The default database encoding has accordingly been set to UTF8.
    The default text search configuration will be set to “english”.

    fixing permissions on existing directory /var/lib/pgsql/data … ok
    creating subdirectories … ok
    selecting default max_connections … 100
    selecting default shared_buffers … 32MB
    creating configuration files … ok
    creating template1 database in /var/lib/pgsql/data/base/1 … ok
    initializing pg_authid … ok
    initializing dependencies … ok
    creating system views … ok
    loading system objects’ descriptions … ok
    creating conversions … ok
    creating dictionaries … ok
    setting privileges on built-in objects … ok
    creating information schema … ok
    vacuuming database template1 … ok
    copying template1 to template0 … ok
    copying template1 to postgres … ok

    Success. You can now start the database server using:

    /usr/bin/postgres -D /var/lib/pgsql/data
    or
    /usr/bin/pg_ctl -D /var/lib/pgsql/data -l logfile start

    LOG: could not translate host name “localhost”, service “5432” to address: Name or service not known
    WARNING: could not create listen socket for “localhost”
    FATAL: could not create any TCP/IP sockets
    LOG: could not translate host name “localhost”, service “5432” to address: Name or service not known
    WARNING: could not create listen socket for “localhost”
    FATAL: could not create any TCP/IP sockets
    LOG: could not translate host name “localhost”, service “5432” to address: Name or service not known
    WARNING: could not create listen socket for “localhost”

    2) cat /var/lib/pgsql/data/pg_log/postgresql-Wed.log
    -> could not find file or directory

    Collapse
    #52622

    Jeff Sposetti
    Moderator

    Any errors or info in the following?

    1) cat /var/lib/pgsql/pgstartup.log
    2) cat /var/lib/pgsql/data/pg_log/postgresql-Wed.log

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)
Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.