Home Forums Sqoop Sqoop –meta-connect

This topic contains 1 reply, has 2 voices, and was last updated by  Saravanan Mohan 4 days, 1 hour ago.

  • Creator
    Topic
  • #57073

    Daro Sdf
    Participant

    I get error when i try invoke command: sqoop job –meta-connect jdbc:hsqldb:hsql://localhost:16000/sqoop –list

    6041 [main] ERROR org.apache.sqoop.tool.JobTool – I/O error performing job operation: java.io.IOException: Exception creating SQL connection
    at org.apache.sqoop.metastore.hsqldb.HsqldbJobStorage.init(HsqldbJobStorage.java:216)
    Caused by: java.sql.SQLException: socket creation error
    at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
    at org.hsqldb.jdbc.jdbcConnection.<init>(Unknown Source)

    If i invoke command: sqoop metastore i get info that server started on port 16000

    My sqoop-site.xml
    <property>
    <name>sqoop.metastore.client.autoconnect.url</name>
    <value>jdbc:hsqldb:hsql://localhost:16000/sqoop</value>
    <description>The connect string to use when connecting to a
    job-management metastore. If unspecified, uses ~/.sqoop/.
    You can specify a different path here.
    </description>
    </property>
    <property>
    <name>sqoop.metastore.server.location</name>
    <value>/tmp/sqoop-metastore/shared.db</value>
    <description>Path to the shared metastore database files.
    If this is not set, it will be placed in ~/.sqoop/.
    </description>
    </property>

    <property>
    <name>sqoop.metastore.server.port</name>
    <value>16000</value>
    <description>Port that this metastore should listen on.
    </description>
    </property>

    If i comment above settings as its default and try invoke command: sqoop job –list it works
    Where is the problem with –meta-connect ?

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #57399

    Saravanan Mohan
    Participant

    Try running the command without meta connect option. Verify it is listing jobs. If it runs success, then your metastore wasn’t configured properly.

    Collapse
Viewing 1 replies (of 1 total)