Home Forums Hortonworks Sandbox ssh to sandbox hangs

Tagged: 

This topic contains 8 replies, has 3 voices, and was last updated by  Seth Lyubich 1 year, 6 months ago.

  • Creator
    Topic
  • #17083

    Hi,
    I installed the sandbox and started it, but cmd-alt-F5 doesn’t do anything in console. I though I might as well ssh into the VM, so I entered

    ssh root@192.168.56.101

    Then I get the prompt:

    root@192.168.56.101‘s password:

    I enter the password according to several messages in this forum. I get this message

    X11 forwarding request failed on channel 0

    I don’t need X11 forwarding right now, so no big deal. But after this it hangs. No prompt ever appears. What am I doing wrong? Thanks

    Antonio

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #17179

    Seth Lyubich
    Keymaster

    Hi Antonio,

    Thanks for letting us know.

    Seth

    Collapse
    #17165

    Repetita iuvant! now also cmd-alt-F5 works. I’ve got my environment set up, unfortunately I didn’t learn the cause of my problems.

    Collapse
    #17156

    > I think there might be an issue if cmd-alt-F5 command does not do anything.
    Agreed
    > Can you try to restart your Sandbox and try cmd-alt-F5 again?
    Same outcome, but ssh went through this time. Eureka!
    > Also can you please let us know if you had any issues during installation or starting Sandbox?
    None that I can tell. During boot I see one FAILED message in red, but it scrolls away before I can read the details. Everything else looks normal.
    > Also, can you please let us know how much memory you are using?
    2GB, I didn’t change that from defaults (or maybe the OVA file defines that)

    Collapse
    #17154

    Seth Lyubich
    Keymaster

    Hi Antonio,

    I think there might be an issue if cmd-alt-F5 command does not do anything. Can you try to restart your Sandbox and try cmd-alt-F5 again? Also can you please let us know if you had any issues during installation or starting Sandbox? Also, can you please let us know how much memory you are using?

    Thanks,
    Seth

    Collapse
    #17119

    I ssh-ed in verbose mode and it appears that it’s the shell that hangs

    debug1: Offering DSA public key: /Users/antonio/.ssh/id_dsa
    debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: password
    root@192.168.56.101‘s password:
    debug1: Authentication succeeded (password).
    Authenticated to 192.168.56.101 ([192.168.56.101]:22).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Tue Mar 12 06:27:49 2013 from 192.168.56.1

    Collapse
    #17115

    The X11 message is just a warning and doesn’t affect connection to any number of other hosts. But just to be sure I edited my .ssh/config and this is the new version of the hangup

    apc-2:~ antonio$ ssh root@192.168.56.101
    root@192.168.56.101‘s password:

    No X11 message, still hanging

    I am using Virtual Box on OS X, following install instructions.

    Collapse
    #17102

    Seth Lyubich
    Keymaster

    Hi Antonio,

    Do you have X11 enabled on your MAC? You can check in /etc/ssh_config to see if X11 forwarding is enabled. If yes you can try to disable X11 and try to connect again.

    Please let us know if this is helpful.

    Thanks,
    Seth

    Collapse
    #17100

    Are you using VirtualBox?? I am using VMware Player (latest version) and have no ssh problems or problems using the console directly. I am running R Studio and the rmr2 library in the sandbox quite satisfactorily. Also run it using VMware Fusion on my Mac OS X laptop. On the PC I use putty to set up the ssh session.

    I recall from other discussions in this forum that networking with Virtualbox is a little brittle.

    Collapse
Viewing 8 replies - 1 through 8 (of 8 total)