Home Forums Hortonworks Sandbox start_metastore_scripts / start_hiveserver2_scripts missing

This topic contains 4 replies, has 3 voices, and was last updated by  peter mcnally 1 month, 1 week ago.

  • Creator
    Topic
  • #57542

    I was able to load the Horton sandbox on Hyper-V. But when I start the server I am getting the below warning:
    /tmp/start_metastore_scripts: No such file or directory
    /tmp/start_hiveserver2_scripts: No such file or directory

    I checked the /tmp folder and the files are not there.
    When I try Beeswax or Hcatalog , I am getting this error.
    Could not connect to sandbox.hortonworks.com:9083

    Need your help

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #62308

    peter mcnally
    Participant

    Scott’s solution worked for me (not sure why these scripts were missing) after I changed the permissions for the two files using
    > chmod a+x start_hiveserver2_script
    > chmod a+x start_metastore_script

    Collapse
    #62285

    peter mcnally
    Participant

    I have the same issue. Was this resolved?

    Collapse
    #60698

    Scott Turnberg
    Participant

    I’m running into this same problem. I re-downloaded the sandbox, copied over the missing scripts and now everything is working.

    Why is a startup script getting stored in /tmp? Is this bad design or is it intended as a timeout for the sandbox?

    Collapse
    #57549

    here is the boot.log
    Updating IP…
    Starting HDP …
    Starting mysql [^[[32;01m OK ^[[0m]
    Starting Knox ldap [^[[32;01m OK ^[[0m]
    Starting Postgre SQL [^[[32;01m OK ^[[0m]
    Starting secondary name node [^[[32;01m OK ^[[0m]
    Starting data node [^[[32;01m OK ^[[0m]
    Starting name node [^[[32;01m OK ^[[0m]
    DEPRECATED: Use of this script to execute hdfs command is deprecated.
    Instead use the hdfs command for it.

    Starting Oozie [^[[32;01m OK ^[[0m]
    Starting zookeeper nodes [^[[33;01mWARNINGS^[[0m]
    JMX enabled by default
    Using config: /etc/zookeeper/conf/zoo.cfg
    Safe mode is OFF
    Starting NFS portmap [^[[32;01m OK ^[[0m]
    Starting Hdfs nfs [^[[32;01m OK ^[[0m]
    Starting hive server [^[[33;01mWARNINGS^[[0m]
    env: /tmp/start_metastore_script: No such file or directory
    Starting Hiveserver2 [^[[33;01mWARNINGS^[[0m]
    env: /tmp/start_hiveserver2_script: No such file or directory
    Starting yarn history server [^[[32;01m OK ^[[0m]
    Starting node manager [^[[32;01m OK ^[[0m]
    Starting mapred history server [^[[32;01m OK ^[[0m]
    Starting webhcat server [^[[32;01m OK ^[[0m]
    Starting resource manager [^[[32;01m OK ^[[0m]
    Starting Knox gateway [^[[32;01m OK ^[[0m]
    Starting Falcon [^[[32;01m OK ^[[0m]
    Safe mode is OFF

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)