Home Forums HDP on Linux – Installation Starting Single Node HMC Service Start failure – CentOS VM

This topic contains 1 reply, has 2 voices, and was last updated by  Sasha J 1 year, 8 months ago.

  • Creator
    Topic
  • #8181

    Max
    Member

    I installed a single node using HMC on a CentOS 6.3 VMware (hostname is just localhost). Installation and testing of HDFS, MapReduce, and ZooKeeper were successful. I had a failure when it got to testing HBase. After rebooting HDFS start fails. I have Operation log below.

    The operation log is:
    Operation Logs

    {
    “2″: {
    “nodeReport”: [],
    “nodeLogs”: []
    },
    “3″: {
    “nodeReport”: [],
    “nodeLogs”: []
    },
    “4″: {
    “nodeReport”: {
    “PUPPET_KICK_FAILED”: [
    "localhost.localdomain"
    ],
    “PUPPET_OPERATION_FAILED”: [],
    “PUPPET_OPERATION_TIMEDOUT”: [],
    “PUPPET_OPERATION_SUCCEEDED”: []
    },
    “nodeLogs”: []

    Thank you in advance for any assistance you can provide.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #8185

    Sasha J
    Moderator

    Your cluster did not complete installation due to HBase issue.
    After reboot, it assumes NEW installation and tried to restart everything from scratch and format namenode (which is already formatted before) and fail on this:
    hadoop::Namenode::Format/Exec[/tmp/checkForFormat.sh]/returns (notice): ERROR: Namenode directory(s) is non empty. Will not format the namenode. List of non-empty namenode dirs /usr/local/hadoop/hdfs/namenode
    Mon Aug 13 08:16:57 -0700 2012 /Stage[2]/Hdp-hadoop::Namenode::Format/Exec[/tmp/checkForFormat.sh]/returns (err): change from notrun to 0 failed: sh /tmp/checkForFormat.sh hdfs /etc/hadoop/conf /var/run/hadoop/hdfs/namenode-formatted /usr/local/hadoop/hdfs/namenode returned 1 instead of one of [0] at /etc/puppet/agent/modules/hdp-hadoop/manifests/namenode/format.pp:49
    Mon Aug 13 08:16:57 -0700 2012 /Stage[2]/Hdp-hadoop::Namenode::Format/Hdp::Exec[set namenode mark]/Anchor[hdp::exec::set namenode mark::begin] (notice): Dependency Exec[/tmp/checkForFormat.sh] has failures: true

    Please, deinstall HMC and puppet, then install HMC and start installation again.

    Make sure that in the service configuration page, you have heap size for HBase Region server set to at least 1024 (region server can not start if heap size is less than 1 Gb)…

    Thank you!
    Sasha

    Collapse
Viewing 1 replies (of 1 total)