The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Windows – Installation Forum

Successful Installation – Cannot Get All Services Running Such As namenode

  • #48459
    Kevin Ellis


    I have followed the instructions outlined here:

    and successfully installed the HDP 2.0 for Windows. However, I have not been able to get all the services running. The number I can get seems to vary everyday, but today I was only able to get 6 of the 15 running.

    Sent all start commands.
    total services
    running services
    not yet running services
    Failed_Start datanode derbyserver historyserver hiveserver2 hwi metastore namenode secondarynamenode templeton

    The alarming one is the namenode. When installing (for the first time) I did select “Delete existing HDP data” which means the namenode should have already been formatted. On the Hadoop command line I have been trying “hdfs namenode -format” to try and format the namenode, but I always receive the error:

    Error: Could not find or load main class (Computer Name).

    I thought this may be an error with my path variable for Java. I have the following set:

    JAVA_HOME is set to C:\Software\Java\jdk1.7.0_51
    Path I have prepended: %JAVA_HOME%\bin;

    The error for all the services that do not start all read the same (except for the first line which changes depending on one of the 9 services):

    Start-Service : Service ‘Apache Hadoop templeton (templeton)’ start failed.
    At C:\hdp\manage_local_hdp_services.ps1:77 char:29
    + $foo = Start-Service <<<< -Name $serviceName.Name -ErrorAction Continue
    + CategoryInfo : OpenError: (System.ServiceProcess.ServiceControl
    ler:ServiceController) [Start-Service], ServiceCommandException
    + FullyQualifiedErrorId : StartServiceFailed,Microsoft.PowerShell.Commands

    I have also tried running everything as a system administrator and everything still fails. I run the ‘start_local_hdp_services’ in the ‘C:\hdp>’ directory as instructed in the installation instructions (twice). I also received a ‘Installation completed successfully’ after following the directions.

    I am simply trying to evaluate the technology by setting up a single node HDP installation, but am getting worried at how difficult it is to get this up and running. I have spent days on forums trying different solutions and am in need of serious assistance. Any help would be VERY much appreciated as I am almost at wit’s end with Hadoop. Thanks again.


  • Author
  • #48637

    Hi Kevin,

    What OS are you running and can you ensure that the Hostname is available to both forward and reverse DNS lookups?



    Kevin Ellis


    Thought I would give an update. I reinstalled HDP 2.0 for Windows a couple more times and still had the same issues as before. I was able to get all the services working except the namenode. However, I received no error messages. Now I was able to accomplish this by modifying the the XML Documents for all the services not working such as the datanode. I would open the XML Document and modify the command Ellis and change it to for every service that wasn’t running (yes, all I did was remove the space). No idea why this worked or even what this line of code does, but all the services started running except the namenode.

    Now, for the past few days I have been trying to get the namenode to work. I have opened the Hadoop command line and have been trying to type ‘hdfs namenode -format’ and receive the following error:

    c:\hdp\hadoop->hdfs namenode -format
    Exception in thread “main” java.lang.NoClassDefFoundError: Ellis
    Caused by: java.lang.ClassNotFoundException: Ellis
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    Could not find the main class: Ellis. Program will exit.

    I have already mentioned how I previously setup JAVA_HOME. This seems to be an error with the HADOOP_CLASSPATH, but I have no idea where to modify it nor have any idea where or what the java main class ELLIS even is. Does anyone know how HDP 2.0 for Windows defines the CLASSPATH? Or even better how during installation the main class ELLIS even got created or where it is? Any help would be much appreciated and I will keep trying.

    David, here is my OS:

    OS Name Microsoft Windows 7 Home Premium
    Version 6.1.7601 Service Pack 1 Build 7601
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name KEVINELLIS-PC
    System Manufacturer Dell Inc.
    System Model Inspiron N5110
    System Type x64-based PC
    Processor Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 2201 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date Dell Inc. A07, 7/18/2011
    SMBIOS Version 2.6
    Windows Directory C:\windows
    System Directory C:\windows\system32
    Boot Device \Device\HarddiskVolume2
    Hardware Abstraction Layer Version = “6.1.7601.17514”
    User Name KevinEllis-PC\Kevin Ellis
    Installed Physical Memory (RAM) 8.00 GB
    Total Physical Memory 7.91 GB
    Available Physical Memory 4.13 GB
    Total Virtual Memory 15.8 GB
    Available Virtual Memory 9.96 GB
    Page File Space 7.91 GB

    I’m worried that my username (because it has a space) is screwing up everything but not sure. Also, David, I’m not sure how to check for DNS lookups, could you advise? Thanks for the help.



    Hi Kevin,

    HDP 2.0 is not supported on Windows 7. There are no plans to make HDP run on Desktop Operating Systems in the future.
    I would advise finding a Windows 2008/2012 64 bit VM or OS to install on.



    Kevin Ellis

    Oh man, now I’m kicking myself for not looking at the operating system requirements in the documentation. Kind of went straight to the installation instructions. Oh well, thanks for the help Dave.


The topic ‘Successful Installation – Cannot Get All Services Running Such As namenode’ is closed to new replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.