HDP on Linux – Installation Forum

TOTALFAILURE at Preparing discovered nodes

  • #11168
    Jonas Kemper
    Member

    hi when trying to start a cluster i have the error:

    Preparing discovered nodes
    Entry Id : 103
    Final result : TOTALFAILURE
    Progress at the end : : 1 / 1 in progress

    output from the check.sh: http://pastebin.com/ZzgDmrQn

    there might be something wrong with the dns, but i can ssh with the server name without password…

to create new topics or reply. | New User Registration

  • Author
    Replies
  • #11178
    Sasha J
    Moderator

    SELinux enabled, MUST be disabled.
    error is:
    [2012:10:17 15:23:58][ERROR][BootStrap][bootstrap.php:187][]: Error when trying to download gpg key using curl –connect-timeout 30 –fail -s -o /tmp/hmcDownloads-1350487408//RPM-GPG-KEY-Jenkins http://public-repo-1.hortonworks.com/HDP-2.0.0.1/repos/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins, output=Array

    Looks like connectivity to outside world does not work.

    #11183
    Seth Lyubich
    Moderator

    Please note that your /etc/hosts file does not have entry for your ethernet ip 192.168.1.102, so it is possible that your host is not discoverable over ethernet. Please try to add it and see if you can ping your host using hostanme.

    Also, please make sure that you can ssh passwordless using both your IP and hostname.

    Seth

    #11263
    Jonas Kemper
    Member

    i disabled selinux, still not working

    “Looks like connectivity to outside world does not work”

    its working, i can run the curl command on console and get the gpg key….
    i can ssh passwordless using both ip and hostname.
    and i can ping both.

    #11264
    Jonas Kemper
    Member

    “$retVal = 0;
    $output = array();
    exec(“curl –connect-timeout 30 –fail -s -o /tmp/hmcDownloads-1350557315//RPM-GPG-KEY-Jenkins http://public-repo-1.hortonworks.com/HDP-1.1.1.16/repos/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins“, $output, $retVal);
    echo $output;
    echo $retVal;

    if i run this php-scipt it returns (in retVal) 0, which is right and is the same as in bootstrap.php…
    but still bootstrap.php is failing…
    i use a proxy server, but i set the variable in the .bash_profile so it should work!?

    #11265
    Jonas Kemper
    Member

    okay its return code 6 from curl:

    CURLE_COULDNT_RESOLVE_HOST (6)
    Couldn’t resolve host. The given remote host was not resolved.

    but if i run it from console it works… does the php thing doesnt use the proxy or dns or stuff??

    #11269
    Sasha J
    Moderator

    Nameresolution is incorrect.
    hostname -f should return something meaningful.
    best way is to place host information in the /etc/hosts file on all nodes.

    #11308
    Jonas Kemper
    Member

    why should nameresolution be incorrect?
    i have currently only one host, i can ping it with hostname and ip,
    hostname -f returns lpt-hadoop-e01.istst.de
    i can get the gpg key with the same command used in the php script, but the script does not work itself…

    #11309
    Jonas Kemper
    Member

    here is another result from check.sh from my current setup : http://sprunge.us/VehH

    #11310
    Sasha J
    Moderator

    This looks pretty much as a timeout on accessing HDP repository…
    Do you have real server of VM?

    #11311
    Sasha J
    Moderator

    This looks pretty much as a timeout on accessing HDP repository…
    Do you have real server or VM?
    Also, I noticed that you trying to download install HDP 2.0, before it was HDP 1.1
    Note that HDP 2.0 is currently in alpha test stage. If you want to try it, please post your questions to relevant Forum thread. This one intended for HDP v1.x, which is production release.

    #11354
    runeetv
    Member

    i use a proxy server, but i set the variable in the .bash_profile so it should work!?

    This is your problem. Ambari runs as root and so cannot load your proxy setting. You should try putting in the proxy settings in root’s bash. And try the same php script as root before you do this.

    #11383
    Jonas Kemper
    Member

    i now changed the proxy settings to store them in /etc/profile.d/proxy.sh so they are there for ALL users!

    i ran the php script as root (im atm doing anything as root) and it works flawless as before (i can dl the gpg key) but the whole process of adding nodes still fails with the same error (timout while running curl…..)

    i think ssh is working, because i have some input in lpt-hadoop-e01.istst.de.out …

    i changed the repository to the new 2.0 version just to test, but with both versions its the same failure…

    im not giving up 😀 and i can get u all infos u need. thanks so far, jk

    #11412
    Jonas Kemper
    Member

    hey, did u answer on my post yesterday? i got an email with test or sth. but see nothing here, im trying to get a vpn connection to my companys network so we could meet on irc or sth. if possible… and i can access the server. im from germyn, so its evening when u answer my psots 😀

    #11433
    Sasha J
    Moderator

    Yes, I sent you e-mail yesterday.
    Here it is again:

    Jonas,
    what do you think about WebEx?
    You are in Germany, right?
    it is 9 hours ahead of us…
    What will be the good time to schedule this?

    Please, respond to it directly, not through the forums.
    Let us take this issues offline.

    #11633
    Jonas Kemper
    Member

    So, we were not able to solve the problem, it is likely to be a problem with the proxy…

    I now installed everything with the gsInstaller-Method, many thanks to the Hortonwoks Support who helped me again!

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.
​