Home Forums Pig UDF in PIG not found

Tagged: , ,

This topic contains 1 reply, has 2 voices, and was last updated by  Dave 11 months, 2 weeks ago.

  • Creator
    Topic
  • #43732

    The error I’m getting is [main] ERROR org.apache.pig.tools.grunt.Grunt - ERROR 2997: Encountered IOException. File access-parser.py does not exist

    access-parser.py is a UDF stored in /tmp/udfs/access-parser.py with user hue and group hdfs, permissions set to 777 (This is the same path, user, and permissions as the default installed udfs I believe)

    The UDF is registered in my script with REGISTER access-parser.py USING jython AS accessParser. I’ve also tried variations with a semicolon at the end of the line, single quotes around the file name, declaring the entire file path, declaring the entire jython path (eg. org.apache.pig.scripting.jython.JythonScriptEngine), completely removing everything from USING onward, etc.

    I’m sure I haven’t accounted for every single variable, but I think I’ve covered the basics in every way I’ve seen a UDF registered, file permissions, and location. I’ve registered python UDF’s in my production environment and using that exact same method doesn’t work here.

    I’m using the default HDP 2.0 Sandbox image in VMWare.

    Does anyone know why Pig can’t find my UDF?

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #45071

    Dave
    Moderator

    Hi Michael,

    In your script have you tried registering the UDF by its exact location – /tmp/udfs/access-parser.py ?
    Is this UDF stored on the local filesystem or HDFS ?

    Thanks

    Dave

    Collapse
Viewing 1 replies (of 1 total)