Home Forums Hortonworks Sandbox Unable to connect Sandbox to Tableau or ODBC drivers

Tagged: , ,

This topic contains 2 replies, has 1 voice, and was last updated by  Jason 3 months ago.

  • Creator
    Topic
  • #55727

    Jason
    Participant

    Hello all,

    Being new to Hadoop, I recently installed the Hortonworks Sandbox on my Windows 7 Premium 64bit machine. However, even after following the tutorials for Tableau, Excel and ODBC, I am unable to connect. Any help would be appreciated!

    I have tried to be as detailed with my computing environment as possible:

    SYSTEM:
    Virtual Box + Hortonworks Sandbox (latest)
    Able to connect with browser on 127.0.0.1:8000, nyse_stocks table created and registered with HCAT, Hive queries on nyse_stocks successful.
    Virtual OS: Red Hat 64bit
    Windows 7 Home Premium 64bit
    Firewall: OFF
    ODBC: Both, 32bit and 64bit installed
    RAM: 1800MB allocated to Virtualbox. I currently only have 4GB on my laptop and am currently awaiting for my 2nd 4GB stick to arrive. The system is a little sluggish but my RAM should arrive soon…

    NETWORK SETTINGS:
    1. Virtual Box Preference:
    NATNetwork CIDR: 10.0.2.0/24 (default settings, with NAT enabled); no port forwarding set
    Host Only:
    Adapter: 192.168.56.1 Mask: 255.255.255.0
    DHCP: 192.168.56.1 Mask: 255.255.255.0 Bounds 102.168.56.101-110
    2. Sandbox Settings:
    Adapter 1: NAT enabled
    Adapter 2: Host only adapter

    3. ~ifconfig results:
    Eth1: 192.168.56.101
    Lo: 127.0.0.1

    ISSUE:
    1.Testing the 64 bit ODBC connection from Administrative Tools:
    Host: 192.168.56.101
    Port: 10000 (also tried 8000, 8888)
    Database default, Hive Server 2, Username: hue (no password)
    RESULT:
    Driver Version: V1.4.5.1005 Running connectivity tests…
    Attempting connection Failed to establish connection
    SQLSTATE: HY000[Hortonworks][HiveODBC] (34) Error from Hive: connect() failed: errno = 10060.
    TESTS COMPLETED WITH ERROR.32 bit ODBC:

    2.Testing the 32 bit ODBC and attempting to connect with Tableau:

    ODBC Settings:
    Server Type: Hive Server 2
    Mechanism: User Name
    Username: sandbox

    Tableau Settings:
    Using Hortonworks Hive
    Server Name: tried 192.168.56.101:10000 and 127.0.0.1:8000
    Authentication: User Name (sandbox)
    RESULT:
    Unable to connect to the ODBC Data Source. Check that the necessary drivers are installed and that the connection properties are valid.
    [Hortonworks][HiveODBC] (34) Error from Hive: connect() failed: errno = 10060.
    Unable to connect to the server “192.168.56.101″. Check that the server is running and that you have access privileges to the requested database.
    Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #55761

    Jason
    Participant

    SOLVED:

    Execute this code in Beeswax/Hive:

    grant SELECT on table <table name> to user hue and
    grant SELECT on table <table name> to user sandbox

    Collapse
    #55734

    Jason
    Participant

    UPDATE:

    Not sure what happened but so far:

    1. 64bit Hortonworks Hive ODBC test connection in ODBC Data Source Administrator System DSN tests connects successfully with the following :
    Host: 127.0.0.1
    Port: 10000
    Hive Server 2
    Username: hue
    No Password

    2. Tableau initially connects to Sandbox with the following info:
    Hortonworks Hadoop Hive
    Server Name: 127.0.0.1 Port: 10000
    HiveServer2
    Authentication: User Name: sandbox

    However after connecting to the default schema and choosing a table, I get the following error:
    [Hortonworks][HiveODBC] (35) Error from Hive: error code: ’40000′ error message: ‘Error while compiling statement: FAILED: HiveAccessControlException Permission denied. Principal [name=sandbox, type=USER] does not have following privileges on Object [type=TABLE_OR_VIEW, name=default.nyse_stocks] : [SELECT]‘.

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)