Home Forums Hue Unable to get HUE to start

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  Dave 5 months, 2 weeks ago.

  • Creator
    Topic
  • #49977

    DeLano Hornbuckle
    Participant

    Installing HUE on a server and cant get it to start.. Looks to install fine but cant get it to start, Any tips on troubleshooting HUE?

    Detecting versions of components…
    HUE_VERSION=2.3.0-101
    HDP=2.0.6
    Hadoop=2.2.0
    HCatalog=0.12.0
    Pig=0.12.0
    Hive=0.12.0
    Oozie=4.0.0
    Error: No matching Packages to list
    Ambari-server=
    HBase=0.96.1
    Starting hue: [FAILED]

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #50318

    Dave
    Moderator

    Hi DeLano,

    That’s good news.
    These “misconfigurations” are because the shells do not exist on the HUE machine.
    On the hue machine you can run:

    yum install pig
    yum install hbase

    This will install the shells here and you can run them from within hue.

    Thanks

    Dave

    Collapse
    #50207

    DeLano Hornbuckle
    Participant

    Ok im able to login HUE now.

    Potential misconfiguration detected message is now giving me

    shell.shelltypes Command ‘/usr/bin/pig -l /dev/null’ for entry ‘pig’ in Shell app configuration cannot be found on the path.
    shell.shelltypes Command ‘/usr/bin/hbase shell’ for entry ‘hbase’ in Shell app configuration cannot be found on the path.

    Collapse
    #50197

    DeLano Hornbuckle
    Participant

    just uploaded the new hue.ini file

    https://copy.com/aISZPVIQON1M

    Collapse
    #50195

    DeLano Hornbuckle
    Participant

    Made the changes, now Beeswax is give me the error below

    14/03/17 07:58:46 ERROR beeswax.Server: Could not create /user/hive/warehouse
    14/03/17 07:58:46 INFO beeswax.Server: Starting metastore at port 8003
    14/03/17 07:58:46 INFO beeswax.Server: Starting beeswaxd at port 8002
    14/03/17 07:58:46 INFO beeswax.Server: Parsed core-default.xml sucessfully. Learned 134 descriptions.
    14/03/17 07:58:46 INFO beeswax.Server: Parsed hdfs-default.xml sucessfully. Learned 137 descriptions.
    14/03/17 07:58:46 INFO beeswax.Server: Parsed mapred-default.xml sucessfully. Learned 169 descriptions.
    14/03/17 07:58:46 WARN beeswax.Server: Could not parse or find: hive-default.xml. Learned 0 description, this is not a problem.
    14/03/17 07:58:46 INFO beeswax.Server: Starting beeswax server on port 8002, talking back to Desktop at 127.0.0.1:8000
    14/03/17 07:58:46 FATAL beeswax.Server: hive.metastore.local is set to false. The Beeswax internal metastore is not supposed to run.

    Collapse
    #50193

    Dave
    Moderator

    Hi DeLano,

    You have a lot of references to localhost in your hue.ini file.
    Please change these to the machine name (or FQDN) of the machine(s) where the components are located.

    Thanks

    Dave

    Collapse
    #50138

    DeLano Hornbuckle
    Participant

    Dave,
    I uploaded the hue.ini file to that same link,

    Thanks again for the help!!

    Collapse
    #50029

    Dave
    Moderator

    Hi DeLano,

    Your hue.ini is configured incorrectly for the beeswax server.
    Can you post a link to it like you did for the logs (you can # hostnames) and then I can give you some settings which will get Hue working.

    Thanks

    Dave

    Collapse
    #49991

    DeLano Hornbuckle
    Participant

    here a link to my logs in /var/log/hue

    https://copy.com/aISZPVIQON1M

    [12/Mar/2014 18:57:47 +0000] supervisor ERROR Process /usr/lib/hue/build/env/bin/hue beeswax_server exited abnormally. Restarting it.
    [12/Mar/2014 18:57:48 +0000] supervisor ERROR Process /usr/lib/hue/build/env/bin/hue beeswax_server exited abnormally. Restarting it.
    [12/Mar/2014 18:57:48 +0000] supervisor ERROR Process /usr/lib/hue/build/env/bin/hue beeswax_server exited abnormally. Restarting it.
    [12/Mar/2014 18:57:49 +0000] supervisor ERROR Process /usr/lib/hue/build/env/bin/hue beeswax_server has restarted more than 3 times in the last 2 seconds
    [12/Mar/2014 18:57:50 +0000] supervisor ERROR Exception in supervisor main loop
    Traceback (most recent call last):
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 386, in main
    wait_loop(sups, options)
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 403, in wait_loop
    shutdown(sups) # shutdown() exits the process
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 215, in shutdown
    sys.exit(1)
    SystemExit: 1

    Collapse
    #49978

    Stanley Nguyen
    Participant

    any error in HUE logs?

    Collapse
Viewing 9 replies - 1 through 9 (of 9 total)