The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Unable to install with Ambari

  • #25090
    Angel Cortes

    Good morning,
    Im trying to install HDP1.2.1 from ambari on Suse11 SP2.

    I have all the repos in a mirror, Ambari-server is installed, ambari registration and ambari-services running in all the host. I configure and arrive to Step9 of the wizzard and then…..freeze.

    The service show 3-6%(depends of the try) and stay for 1hour and then report a fail with all the services in timeout in all the servers.
    And you can read in the logs this message:
    [HDP-UTILS-|] Can’t provide file ‘./snappy/snappy-1.0.5-1.x86_64.rpm’ from repository ‘HDP-UTILS-’
    – Download (curl) error for ‘’:
    Error code: Connection failed
    Error message: Couldn’t resolve host ‘’

    I selected USE LOCAL REPOSITORIES, and i have the snappy in the HDP-UTILS repository, why is trying to get it outside?

    I tried to disable the HDP.repo and the HDP-UTILS.repo created by ambari, but then is created again in the next retry. I created my repositories with other names to not be overwriten, set priority to 1…Nothing works. It uses the HDP and the HDP-UTILS isntead of mine.

    Please any help?

  • Author
  • #25091
    Angel Cortes

    new problem…

    I passed the repo problem with a proxy, only to try this distribution as i need to compare with others to prepare a huge install for a bank account,
    now the ambari UI is halt in “installing ganglia” for 30 minutes with all the other services in “pending”, but in logs i can see:
    INFO 2013-05-10 09:17:12,861 – The live status for component GANGLIA_SERVER of service GANGLIA is {‘msg’: ”, ‘componentName’: ‘GANGLIA_SERVER’, ‘serviceName’: u’GANGLIA’, ‘status’: ‘INSTALLED’, ‘clusterName’: u’HDP’}
    INFO 2013-05-10 09:17:12,862 – Got live status for component GANGLIA_SERVER of service GANGLIA of cluster HDP
    {‘clusterName’: u’HDP’,
    ‘componentName’: ‘GANGLIA_SERVER’,
    ‘msg’: ”,
    ‘serviceName’: u’GANGLIA’,
    ‘status’: ‘INSTALLED’}

    And for other services…

    INFO 2013-05-10 09:17:12,845 – Got live status for component JOBTRACKER of service MAPREDUCE of cluster HDP
    {‘clusterName’: u’HDP’,
    ‘componentName’: ‘JOBTRACKER’,
    ‘msg’: ”,
    ‘serviceName’: u’MAPREDUCE’,
    ‘status’: ‘INSTALLED’}

    Thats is absurd, yesterday i had this problem too and one hour later the ambari report a timeout and no errors, in logs.

    In every try to reinstal the cluster i do an “ambari-server reset” to avoid problems with the database.

    Why i cant install it?


    HI Angel,

    Can you try a re-install without doing the ambari-server reset? In this case you will need to give a different name for the cluster.


    Angel Cortes

    Hi Ted,
    That’s the first try i did.

    I finally get the cluster for the PoC running.
    After setting all the repositories and a lot of different errors i decide to read the logs “carefully”(78.000 lines) and found that a lot of problems come from the paralel installation of components and the use of zypper.

    In a lot of nodes i found messages of “Zypper fail cause a lock by PID (xxxxx)” and that PID is from another zypper trying to install other component.

    After read this error, I tried the retry of the install and wait for timeout until the checks get all the component installed, and in the 3rd retry, all the components are installed and the cluster is running.

    Thx for your help.


    Hi Angel,

    It’s good to hear that you finally got the POC cluster up and running.




    Can you tell me how to install postgre with below version in SLES
    libpq5 9.1.5-0.2.1
    postgresql 8.3.20-0.4.1
    postgresql-init 9.1-
    postgresql-server 8.3.20-0.4.1



    Hi Pariksheet,

    Is your version of SLES registered? If it is not you’ll not have access to the zypper repositories necessary to download the sofware.


The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.