The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Oozie Forum

Unable to run any oozie job

  • #53017
    Sandeep KS
    Participant

    My core-site.xml contains following properties
    <property>
    <name>hadoop.proxyuser.oozie.groups</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.oozie.hosts</name>
    <value>*</value>
    </property>
    After this addition entire hadoop cluster is re-started
    Also my oozie-site.xml contains
    <property>
    <name>oozie.service.ProxyUserService.proxyuser.oozie.hosts</name>
    <value>*</value>
    </property>

    <property>
    <name>oozie.service.ProxyUserService.proxyuser.oozie.groups</name>
    <value>*</value>
    </property>
    After adding these properties oozie server is re-started.

    When I run the command, oozie job -config test1-WF/job.properties -run -oozie ‘http://namenode1-01:11000/oozie’, I am getting
    Error: E0501 : E0501: Could not perform authorization operation, User: root is not allowed to impersonate root.
    Any Ideas?

    Rgds,
    Sandeep

  • Author
    Replies
  • #54249
    Amudhan K
    Participant

    Hello Sandeep KS,
    Your username is root and not oozie. so change your core-site.xml like then and restart your cluster, then it will work.

    <property>
    <name>hadoop.proxyuser.root.groups</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.root.hosts</name>
    <value>*</value>
    </property>

    #59899
    Ahil Ponarul
    Participant

    Which core-site.xml file is it? I looked at mine in my etc/oozie/conf.dist/hadoop-conf and it looked nothing like this one. Am I completely in the wrong directory?

    Thank you much,

    AJ

    #73332

    Hi

    I am getting below error. could some help me in fixing this issue even after updating the /etc/hadoop/conf/core-site.xml

    oozie process is owned by oozie.

    Thanks
    Ramabadran

    [root@sandbox ~]# cd /usr/share/doc/oozie-4.0.0.2.1.1.0/examples/apps//pig
    [root@sandbox pig]# oozie job -oozie http://localhost:11000/oozie -config job.properties -run
    Error: E0501 : E0501: Could not

    <property>
    <name>hadoop.proxyuser.oozie.hosts</name>
    <value>sandbox.hortonworks.com</value>
    </property>

    <property>
    <name>hadoop.proxyuser.oozie.groups</name>
    <value>hadoop</value>
    </property>

The forum ‘Oozie’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.