Hortonworks Sandbox Forum

unable to run basic pig tutorials

  • #57393
    Jaiwant Jonathan

    I get this error in the log when I try to execute Pig scripts. .

    ls: cannot access /usr/lib/hive/lib/slf4j-api-*.jar: No such file or directory

    The scripts that worked earlier are not working now. TIA for any suggestions.

to create new topics or reply. | New User Registration

  • Author
  • #57394
    Ramesh Babu

    pig unable to find the jar file. are you added any new jar’s. plaese find the jar file in your system and copy to the /usr/lib/hive/lib as follows. switch to root user then
    # find / -name slf4j-api-*.jar
    cp <source location> /usr/lib/hive/lib/

    Jaiwant Jonathan

    That worked. The only issue was the find command returned several versions of the jar files. I went with the highest version. Thank you.

The topic ‘unable to run basic pig tutorials’ is closed to new replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.