Hortonworks Sandbox Forum

Unable to SSH into Sandbox 1.3 version

  • #30621
    Ram Kotamaraja


    I am using Sandbox v1.3 with VirtualBox 4.2.x on Macbook Pro.

    When I run the Sandbox, I get the following info:

    Browser access:
    SSH Access:
    I installed Ambari on the VM and I can access Ambari at:

    When I try to access SSH, I get the following errors:
    $ ssh root@
    Message: ssh: Could not resolve hostname nodename nor servname provided, or not known
    $ ssh root@
    ssh: connect to host port 22: Connection refused

    I logged into VM and tried

    #netstat -anp|grep 2222
    There is no output. Basically looks like port 2222 is not open.

    I am wondering what I am doing wrong? Can somebody shed light on how I can do SSH to Sandbox?

to create new topics or reply. | New User Registration

  • Author
  • #30664
    Wes Floyd

    I’m having the same problem. Even when I add a new network adapter (which gets DHCP address of I can’t ping the system or ssh into it.

    I don’t think the issue is related to SELinux or IPTables. I’ve tried disabling both.

    Note: I’m also testing on VirtualBox. I’ll retry this test on VMWare.

    Wes Floyd

    Testing this on VMWare I was able to immediately SSH into the sandbox machine. Perhaps there is an issue with the default Virtualbox network settings?

    Ram Kotamaraja


    Thanks for the input. I will try VMWare.

    Sasha J

    command should be:

    ssh -p 2222 root@

    Sandbox uses private network and NAT.

    Thank you!

    Ram Kotamaraja


    You rock. Thats works like a champ.

    Cyril F

    what is the root password?

    Sasha J


    Aditya Y

    Hi Sasha, unfortunately the solution you provided didnt work for me!!
    ssh -p 2222 root@
    ssh root@ -p 2222

    Both the commands gave me same response. Connection refused!!!
    could you pls help?


    Hi Sasha,
    Even I m getting same error connection refused for your provided command => ssh -p 2222 root@ and getting error cound not resolver host name or service not know.
    for first command => $ ssh root@

    surya nemani

    Hi Guys,
    Please share how to resolve this connection error. I am also facing a similar issue.
    ssh: connect to host port 22: Connection refused

    I tired all the options but could not connect.
    Why is this an issue? why there is no proper guidance for this from the Horton Works?

    Thank You in Advance if somebody has an answer for this.


    Hi Surya,

    Please use this command:

    ssh root@ -p 2222

    You should be able to connect into the sandbox.



You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.