Home Forums Hue unable to start hue on HDP-2.1.2

This topic contains 7 replies, has 3 voices, and was last updated by  Neelakanta Kawad 6 days ago.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #64712

    Neelakanta Kawad
    Participant

    I resolved this issue. Problem was with one of the configuration parameter in hue.ini file.

    [desktop]
    # If set to false, runcpserver will not actually start the web server.
    #enable_server=no this should be enable_server=yes

    !!Thanks!!

    Collapse
    #64476

    Neelakanta Kawad
    Participant

    Hue installed and service is running.. Below is my Hue.ini

    [desktop]
    kredentials_dir=”/tmp”
    send_dbug_messages=1
    secret_key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    # Webserver listens on this address and port
    http_host=hue_server
    http_port=8000

    # Set to true to use CherryPy as the webserver, set to false
    # to use Spawning as the webserver. Defaults to Spawning if
    # key is not specified.
    use_cherrypy_server=true

    # Webserver runs as this user
    server_user=hue
    server_group=hadoop

    # No SSL certificates
    ###########################################################################
    # Settings to configure your Hadoop cluster.
    ###########################################################################
    [hadoop]
    # Configuration for HDFS NameNode
    # ————————————————————————
    [[hdfs_clusters]]

    [[[default]]]
    # Enter the filesystem uri
    fs_defaultfs=hdfs://fs_defaultfs.fqdn:8020

    # Use WebHdfs/HttpFs as the communication mechanism. To fallback to
    # using the Thrift plugin (used in Hue 1.x), this must be uncommented
    # and explicitly set to the empty value.
    webhdfs_url=http://yarn.fqdn:50070/webhdfs/v1/

    # Configuration for Yarn
    # ————————————————————————
    [[yarn_clusters]]
    [[[default]]]
    # URL of the ResourceManager API
    resourcemanager_api_url=http://resourcemanager.fqdn:8088
    # URL of the ProxyServer API
    proxy_api_url=http://resourcemanager.fqdn:8088
    # URL of the HistoryServer API
    history_server_api_url=http://HistoryServer.fqdn:19888
    # URL of the NodeManager API
    node_manager_api_url=http://NodeManager.fqdn:8042
    ###########################################################################
    # Settings to configure liboozie
    ###########################################################################
    [liboozie]
    # The URL where the Oozie service runs on. This is required in order for
    # users to submit jobs.
    oozie_url=http://oozie.fqdn:11000/oozie

    Collapse
    #62488

    Dave
    Moderator

    Hi Umesh / Neelakanta,

    Can you attach your hue.ini here and also some logs from /var/log/hue.

    There is a configuration issue if hue does not start correctly – so having your hue.ini would be very helpful.

    Thanks

    Dave

    Collapse
    #62292

    Neelakanta Kawad
    Participant

    Hi Umesh
    I am at same situation.unable to start Hue after installation.
    could you pls share if you found any solution.

    Thanks

    Collapse
    #55712

    Dave
    Moderator

    Hi Umesh,

    Can you please attach more lines from the supervisor log, preferably 15 – 20 lines above the error.

    Thanks

    Dave

    Collapse
    #55460

    Umesh
    Participant

    please find here the log from my supervisor.log file

    [09/Jun/2014 11:03:47 +0000] supervisor ERROR Exception in supervisor main loop
    Traceback (most recent call last):
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 386, in main
    wait_loop(sups, options)
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 403, in wait_loop
    shutdown(sups) # shutdown() exits the process
    File “/usr/lib/hue/desktop/core/src/desktop/supervisor.py”, line 215, in shutdown
    sys.exit(1)
    SystemExit: 1
    [09/Jun/2014 11:03:47 +0000] supervisor WARNING Supervisor shutting down!
    [09/Jun/2014 11:03:47 +0000] supervisor WARNING Waiting for children to exit for 5 seconds…

    Collapse
    #55459

    Umesh
    Participant

    i have tried following solutions but no luck yet,

    added following contents to sudoers file,

    hue ALL=(ALL) ALL
    hue ALL=(ALL) NOPASSWD: /sbin/chkconfig
    hue ALL=(ALL) NOPASSWD: /sbin/service
    hue ALL=(ALL) NOPASSWD: /bin/kill

    also tried restarting namenode but no luck so far

    Collapse
Viewing 7 replies - 1 through 7 (of 7 total)